# CVE-2015-3154: Zenario CMS vulnerable to CRLF injection

> Remote attackers can inject arbitrary HTTP headers and conduct response splitting via CRLF sequences in email headers using Zend Framework.

- **Severity:** Medium 6.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 27 Jan 2020
- **Updated:** 6 Aug 2024
- **Also known as:** CLSA-2026-1787214807, GHSA-5957-5crx-79jx, MGASA-2015-0241, UBUNTU-CVE-2015-3154

## What is CVE-2015-3154?

CVE-2015-3154 is a medium-severity vulnerability in Zend Framework, published on 27 Jan 2020. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

CRLF injection vulnerability in Zend\Mail (Zend_Mail) in Zend Framework before 1.12.12, 2.x before 2.3.8, and 2.4.x before 2.4.1 allows remote attackers to inject arbitrary HTTP headers and conduct HTTP response splitting attacks via CRLF sequences in the header of an email.

Weakness: CWE-74 (Improper Neutralization of Special Elements in Output Used by a Downstream Component)

## Which versions are affected by CVE-2015-3154?

12 open source packages ship an affected version, including zendframework/zend-http, zendframework/zendframework and zendframework/zendframework1. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `zendframework/zend-http` | Packagist | All versions | 1.12.12 |
| `zendframework/zend-http` | Packagist | All versions | 1.12.12 |
| `zendframework/zend-http` | Packagist | From 2.0.0beta4 | 2.3.8 |
| `zendframework/zend-http` | Packagist | From 2.0.0beta4 | 2.3.8 |
| `zendframework/zend-http` | Packagist | From 2.4.0rc1 | 2.4.1 |
| `zendframework/zend-http` | Packagist | From 2.4.0rc1 | 2.4.1 |
| `zendframework/zendframework` | Packagist | From 2.0.0beta4 | 2.3.8 |
| `zendframework/zendframework` | Packagist | From 2.0.0beta4 | 2.3.8 |
| `zendframework/zendframework` | Packagist | From 2.4.0rc1 | 2.4.1 |
| `zendframework/zendframework` | Packagist | From 2.4.0rc1 | 2.4.1 |
| `zendframework/zendframework1` | Packagist | All versions | 1.12.12 |
| `zendframework/zendframework1` | Packagist | All versions | 1.12.12 |

Products: Zend Zend Framework.

## How do I fix CVE-2015-3154?

Upgrade zendframework/zend-http to a fixed version for your release line: 1.12.12, 2.3.8 or 2.4.1.

## Is CVE-2015-3154 being exploited?

There is no known exploitation of CVE-2015-3154 in the wild and no public exploit code.

## Other vulnerabilities in Zend Framework

- [CVE-2020-29312](https://insights.sbomify.com/CVE-2020-29312/): Deserialization in n/a (critical 9.8)
- [CVE-2015-1555](https://insights.sbomify.com/CVE-2015-1555/): Auth bypass in n/a (critical 9.1)
- [CVE-2015-1786](https://insights.sbomify.com/CVE-2015-1786/): Zend Framework CSRF Vulnerability (high 8.8)
- [CVE-2015-7503](https://insights.sbomify.com/CVE-2015-7503/): Zend Framework Information Disclosure (high 7.5)
- [CVE-2014-2685](https://insights.sbomify.com/CVE-2014-2685/): Auth bypass in n/a (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2015-3154 and fix it if it is affected.

What it is: CVE-2015-3154 is a medium-severity vulnerability in Zend Framework, published on 27 Jan 2020. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2015-3154 in the wild and no public exploit code.

Affected packages and fixed versions:
- zendframework/zend-http (Packagist): affected all versions; fixed in 1.12.12
- zendframework/zend-http (Packagist): affected all versions; fixed in 1.12.12
- zendframework/zend-http (Packagist): affected from 2.0.0beta4; fixed in 2.3.8
- zendframework/zend-http (Packagist): affected from 2.0.0beta4; fixed in 2.3.8
- zendframework/zend-http (Packagist): affected from 2.4.0rc1; fixed in 2.4.1
- zendframework/zend-http (Packagist): affected from 2.4.0rc1; fixed in 2.4.1
- zendframework/zendframework (Packagist): affected from 2.0.0beta4; fixed in 2.3.8
- zendframework/zendframework (Packagist): affected from 2.0.0beta4; fixed in 2.3.8
- zendframework/zendframework (Packagist): affected from 2.4.0rc1; fixed in 2.4.1
- zendframework/zendframework (Packagist): affected from 2.4.0rc1; fixed in 2.4.1
- zendframework/zendframework1 (Packagist): affected all versions; fixed in 1.12.12
- zendframework/zendframework1 (Packagist): affected all versions; fixed in 1.12.12

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2015-3154/ (Markdown: https://insights.sbomify.com/CVE-2015-3154/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2015-3154
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2015-3154
- OSV: https://osv.dev/vulnerability/CVE-2015-3154

---
From sbomify Insights: https://insights.sbomify.com/CVE-2015-3154/
Summaries are generated and may contain mistakes; the official description above is the record.
