# CVE-2015-3171: sosreport sensitive information disclosure via weak permissions of the generated archives

> Local attackers can read sensitive data from sosreport archives due to weak file permissions in the diagnostic tool.

- **Severity:** Medium 5.5 (`CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 25 Jul 2017
- **Updated:** 6 Aug 2024
- **Also known as:** DEBIAN-CVE-2015-3171, GHSA-gw46-8559-cggp, PYSEC-2017-72

## What is CVE-2015-3171?

CVE-2015-3171 is a medium-severity vulnerability in n/a, published on 25 Jul 2017. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

sosreport 3.2 uses weak permissions for generated sosreport archives, which allows local users with access to /var/tmp/ to obtain sensitive information by reading the contents of the archive.

Weakness: CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2015-3171?

3 open source packages ship an affected version, including sosreport. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `sosreport` | PyPI | All versions | 3.3 |
| `sosreport` | PyPI | All versions | 3.3 |
| `sosreport` | PyPI | From 3.0 | None |

Products: Sos Project Sos.

## How do I fix CVE-2015-3171?

Upgrade sosreport to 3.3 or later.

## Is CVE-2015-3171 being exploited?

There is no known exploitation of CVE-2015-3171 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2015-3171 and fix it if it is affected.

What it is: CVE-2015-3171 is a medium-severity vulnerability in n/a, published on 25 Jul 2017. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2015-3171 in the wild and no public exploit code.

Affected packages and fixed versions:
- sosreport (PyPI): affected all versions; fixed in 3.3
- sosreport (PyPI): affected all versions; fixed in 3.3
- sosreport (PyPI): affected from 3.0; no fix listed

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2015-3171/ (Markdown: https://insights.sbomify.com/CVE-2015-3171/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2015-3171
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2015-3171
- OSV: https://osv.dev/vulnerability/CVE-2015-3171

---
From sbomify Insights: https://insights.sbomify.com/CVE-2015-3171/
Summaries are generated and may contain mistakes; the official description above is the record.
