CVE-2015-3174 Moodle does not set the RISK_XSS bit for graders
Authenticated users can perform cross-site scripting attacks via crafted gradebook feedback in Moodle quiz grading due to missing risk flags.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2015-3174?
CVE-2015-3174 is a low-severity cross-site scripting vulnerability in Moodle Moodle, published on 1 Jun 2015. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Official description
mod/quiz/db/access.php in Moodle through 2.5.9, 2.6.x before 2.6.11, 2.7.x before 2.7.8, and 2.8.x before 2.8.6 does not set the RISK_XSS bit for graders, which allows remote authenticated users to conduct cross-site scripting (XSS) attacks via crafted gradebook feedback during manual quiz grading.
Weakness: CWE-79
Which versions are affected by CVE-2015-3174?
6 open source packages ship an affected version, including moodle/moodle. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
moodle/moodle Packagist | All versions | 2.6.11 |
moodle/moodle Packagist | All versions | 2.6.11 |
moodle/moodle Packagist | From 2.7.0 | 2.7.8 |
moodle/moodle Packagist | From 2.7.0 | 2.7.8 |
moodle/moodle Packagist | From 2.8.0 | 2.8.6 |
moodle/moodle Packagist | From 2.8.0 | 2.8.6 |
Products include Moodle Moodle.
How do I fix CVE-2015-3174?
Upgrade moodle/moodle to a fixed version for your release line: 2.6.11, 2.7.8 or 2.8.6.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2015-3174 being exploited?
There is no known exploitation of CVE-2015-3174 in the wild and no public exploit code.
Other vulnerabilities in Moodle Moodle
- CVE-2006-4935 File upload in n/a
- CVE-2006-4936 Moodle does not properly validate module instance id
- CVE-2004-2233 Unknown "front page vulnerability with Moodle servers" for Moodle before 1.3.2 has unknown impact and attack vectors.
- CVE-2004-2235 Cross-site scripting in n/a
- CVE-2004-2236 Other in n/a
Sources
Also known as GHSA-6r7x-6q98-qcqp.