CVE-2015-3175 Moodle Arbitrary Redirect
Remote attackers can redirect users to malicious sites via error pages, facilitating phishing attacks against Moodle users.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2015-3175?
CVE-2015-3175 is a medium-severity vulnerability in Moodle Moodle, published on 1 Jun 2015. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Official description
Multiple open redirect vulnerabilities in Moodle through 2.5.9, 2.6.x before 2.6.11, 2.7.x before 2.7.8, and 2.8.x before 2.8.6 allow remote attackers to redirect users to arbitrary web sites and conduct phishing attacks via vectors involving an error page that links to a URL from an HTTP Referer header.
Which versions are affected by CVE-2015-3175?
8 open source packages ship an affected version, including moodle/moodle. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
moodle/moodle Packagist | All versions to 2.5.9 | None |
moodle/moodle Packagist | All versions to 2.5.9 | None |
moodle/moodle Packagist | From 2.6.0 | 2.6.11 |
moodle/moodle Packagist | From 2.6.0 | 2.6.11 |
moodle/moodle Packagist | From 2.7.0 | 2.7.8 |
moodle/moodle Packagist | From 2.7.0 | 2.7.8 |
2 more packages
moodle/moodle Packagist | From 2.8.0 | 2.8.6 |
moodle/moodle Packagist | From 2.8.0 | 2.8.6 |
Products include Moodle Moodle.
How do I fix CVE-2015-3175?
Upgrade moodle/moodle to a fixed version for your release line: 2.6.11, 2.7.8 or 2.8.6.
Is CVE-2015-3175 being exploited?
There is no known exploitation of CVE-2015-3175 in the wild and no public exploit code.
Other vulnerabilities in Moodle Moodle
- CVE-2006-4935 File upload in n/a
- CVE-2006-4936 Moodle does not properly validate module instance id
- CVE-2004-2233 Unknown "front page vulnerability with Moodle servers" for Moodle before 1.3.2 has unknown impact and attack vectors.
- CVE-2004-2235 Cross-site scripting in n/a
- CVE-2004-2236 Other in n/a
Sources
Also known as GHSA-h798-h7ff-93xv.