CVE-2015-3176 Moodle allows attackers obtain full-name information
Remote attackers can obtain sensitive full-name information by attempting to self-register in Moodle's account-confirmation feature.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2015-3176?
CVE-2015-3176 is a medium-severity vulnerability in Moodle Moodle, published on 1 Jun 2015. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
The account-confirmation feature in login/confirm.php in Moodle through 2.5.9, 2.6.x before 2.6.11, 2.7.x before 2.7.8, and 2.8.x before 2.8.6 allows remote attackers to obtain sensitive full-name information by attempting to self-register.
Weakness: CWE-200
Which versions are affected by CVE-2015-3176?
6 open source packages ship an affected version, including moodle/moodle. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
moodle/moodle Packagist | All versions | 2.6.11 |
moodle/moodle Packagist | All versions | 2.6.11 |
moodle/moodle Packagist | From 2.7.0 | 2.7.8 |
moodle/moodle Packagist | From 2.7.0 | 2.7.8 |
moodle/moodle Packagist | From 2.8.0 | 2.8.6 |
moodle/moodle Packagist | From 2.8.0 | 2.8.6 |
Products include Moodle Moodle.
How do I fix CVE-2015-3176?
Upgrade moodle/moodle to a fixed version for your release line: 2.6.11, 2.7.8 or 2.8.6.
Is CVE-2015-3176 being exploited?
There is no known exploitation of CVE-2015-3176 in the wild and no public exploit code.
Other vulnerabilities in Moodle Moodle
- CVE-2006-4935 File upload in n/a
- CVE-2006-4936 Moodle does not properly validate module instance id
- CVE-2004-2233 Unknown "front page vulnerability with Moodle servers" for Moodle before 1.3.2 has unknown impact and attack vectors.
- CVE-2004-2235 Cross-site scripting in n/a
- CVE-2004-2236 Other in n/a
Sources
Also known as GHSA-fqrg-vmvj-jv3x.