CVE-2015-3178 Moodle cross-site scripting (XSS) vulnerability
Authenticated users can inject malicious scripts into Moodle via crafted strings, potentially compromising other users' sessions or data.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2015-3178?
CVE-2015-3178 is a low-severity cross-site scripting vulnerability in Moodle Moodle, published on 1 Jun 2015. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Official description
Cross-site scripting (XSS) vulnerability in the external_format_text function in lib/externallib.php in Moodle through 2.5.9, 2.6.x before 2.6.11, 2.7.x before 2.7.8, and 2.8.x before 2.8.6 allows remote authenticated users to inject arbitrary web script or HTML into an external application via a crafted string that is visible to web services.
Weakness: CWE-79
Which versions are affected by CVE-2015-3178?
6 open source packages ship an affected version, including moodle/moodle. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
moodle/moodle Packagist | All versions | 2.6.11 |
moodle/moodle Packagist | All versions | 2.6.11 |
moodle/moodle Packagist | From 2.7.0 | 2.7.8 |
moodle/moodle Packagist | From 2.7.0 | 2.7.8 |
moodle/moodle Packagist | From 2.8.0 | 2.8.6 |
moodle/moodle Packagist | From 2.8.0 | 2.8.6 |
Products include Moodle Moodle.
How do I fix CVE-2015-3178?
Upgrade moodle/moodle to a fixed version for your release line: 2.6.11, 2.7.8 or 2.8.6.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2015-3178 being exploited?
There is no known exploitation of CVE-2015-3178 in the wild and no public exploit code.
Other vulnerabilities in Moodle Moodle
- CVE-2006-4935 File upload in n/a
- CVE-2006-4936 Moodle does not properly validate module instance id
- CVE-2004-2233 Unknown "front page vulnerability with Moodle servers" for Moodle before 1.3.2 has unknown impact and attack vectors.
- CVE-2004-2235 Cross-site scripting in n/a
- CVE-2004-2236 Other in n/a
Sources
Also known as GHSA-9fmw-m4qx-6cq8.