CVE-2015-3179 Moodle allows attackers to bypass intended login restrictions

Low 3.5 Published Updated

Authenticated attackers can bypass login restrictions by exploiting unconfirmed suspended accounts in Moodle.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2015-3179?

CVE-2015-3179 is a low-severity authentication bypass vulnerability in Moodle Moodle, published on 1 Jun 2015. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

login/confirm.php in Moodle through 2.5.9, 2.6.x before 2.6.11, 2.7.x before 2.7.8, and 2.8.x before 2.8.6 allows remote authenticated users to bypass intended login restrictions by leveraging access to an unconfirmed suspended account.

Weakness: CWE-264

Which versions are affected by CVE-2015-3179?

6 open source packages ship an affected version, including moodle/moodle. It affects 1 product.

PackageAffectedFixed in
moodle/moodle PackagistAll versions2.6.11
moodle/moodle PackagistAll versions2.6.11
moodle/moodle PackagistFrom 2.7.02.7.8
moodle/moodle PackagistFrom 2.7.02.7.8
moodle/moodle PackagistFrom 2.8.02.8.6
moodle/moodle PackagistFrom 2.8.02.8.6

Products include Moodle Moodle.

How do I fix CVE-2015-3179?

Upgrade moodle/moodle to a fixed version for your release line: 2.6.11, 2.7.8 or 2.8.6.

Upgrade, and rotate credentials and sessions that may have been exposed. More about Authentication bypass.

Is CVE-2015-3179 being exploited?

There is no known exploitation of CVE-2015-3179 in the wild and no public exploit code.

All Moodle Moodle vulnerabilities

Sources

Also known as GHSA-4ppg-2mx6-fqx9.

Is CVE-2015-3179 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free