CVE-2015-3180 Moodle allows attackers to obtain sensitive course-structure information

Medium 4.0 Published Updated

Authenticated users with suspended enrolments can access sensitive course structure information in Moodle.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2015-3180?

CVE-2015-3180 is a medium-severity vulnerability in Moodle Moodle, published on 1 Jun 2015. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

lib/navigationlib.php in Moodle through 2.5.9, 2.6.x before 2.6.11, 2.7.x before 2.7.8, and 2.8.x before 2.8.6 allows remote authenticated users to obtain sensitive course-structure information by leveraging access to a student account with a suspended enrolment.

Weakness: CWE-200

Which versions are affected by CVE-2015-3180?

6 open source packages ship an affected version, including moodle/moodle. It affects 1 product.

PackageAffectedFixed in
moodle/moodle PackagistAll versions2.6.11
moodle/moodle PackagistAll versions2.6.11
moodle/moodle PackagistFrom 2.7.02.7.8
moodle/moodle PackagistFrom 2.7.02.7.8
moodle/moodle PackagistFrom 2.8.02.8.6
moodle/moodle PackagistFrom 2.8.02.8.6

Products include Moodle Moodle.

How do I fix CVE-2015-3180?

Upgrade moodle/moodle to a fixed version for your release line: 2.6.11, 2.7.8 or 2.8.6.

Is CVE-2015-3180 being exploited?

There is no known exploitation of CVE-2015-3180 in the wild and no public exploit code.

All Moodle Moodle vulnerabilities

Sources

Also known as GHSA-688p-pgj4-77hh.

Is CVE-2015-3180 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free