CVE-2015-3181 Moodle allows attackers to bypass file-management restrictions
Authenticated users can bypass file management restrictions to upload private files via web services despite revoked capabilities.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2015-3181?
CVE-2015-3181 is a medium-severity missing authorization vulnerability in Moodle Moodle, published on 1 Jun 2015. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
files/externallib.php in Moodle through 2.5.9, 2.6.x before 2.6.11, 2.7.x before 2.7.8, and 2.8.x before 2.8.6 does not consider the moodle/user:manageownfiles capability before approving a private-file upload, which allows remote authenticated users to bypass intended file-management restrictions by using web services to perform uploads after this capability has been revoked.
Weakness: CWE-264
Which versions are affected by CVE-2015-3181?
6 open source packages ship an affected version, including moodle/moodle. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
moodle/moodle Packagist | All versions | 2.6.11 |
moodle/moodle Packagist | All versions | 2.6.11 |
moodle/moodle Packagist | From 2.7.0 | 2.7.8 |
moodle/moodle Packagist | From 2.7.0 | 2.7.8 |
moodle/moodle Packagist | From 2.8.0 | 2.8.6 |
moodle/moodle Packagist | From 2.8.0 | 2.8.6 |
Products include Moodle Moodle.
How do I fix CVE-2015-3181?
Upgrade moodle/moodle to a fixed version for your release line: 2.6.11, 2.7.8 or 2.8.6.
Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.
Is CVE-2015-3181 being exploited?
There is no known exploitation of CVE-2015-3181 in the wild and no public exploit code.
Other vulnerabilities in Moodle Moodle
- CVE-2006-4935 File upload in n/a
- CVE-2006-4936 Moodle does not properly validate module instance id
- CVE-2004-2233 Unknown "front page vulnerability with Moodle servers" for Moodle before 1.3.2 has unknown impact and attack vectors.
- CVE-2004-2235 Cross-site scripting in n/a
- CVE-2004-2236 Other in n/a
Sources
Also known as GHSA-622h-cjgg-5mx6.