# CVE-2015-3181: Moodle allows attackers to bypass file-management restrictions

> Authenticated users can bypass file management restrictions to upload private files via web services despite revoked capabilities.

- **Severity:** Medium 4.0 (`AV:N/AC:L/Au:S/C:N/I:P/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 1 Jun 2015
- **Updated:** 6 Aug 2024
- **Also known as:** GHSA-622h-cjgg-5mx6

## What is CVE-2015-3181?

CVE-2015-3181 is a medium-severity missing authorization vulnerability in Moodle Moodle, published on 1 Jun 2015. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

files/externallib.php in Moodle through 2.5.9, 2.6.x before 2.6.11, 2.7.x before 2.7.8, and 2.8.x before 2.8.6 does not consider the moodle/user:manageownfiles capability before approving a private-file upload, which allows remote authenticated users to bypass intended file-management restrictions by using web services to perform uploads after this capability has been revoked.

Weakness: CWE-264

## Which versions are affected by CVE-2015-3181?

6 open source packages ship an affected version, including moodle/moodle. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `moodle/moodle` | Packagist | All versions | 2.6.11 |
| `moodle/moodle` | Packagist | All versions | 2.6.11 |
| `moodle/moodle` | Packagist | From 2.7.0 | 2.7.8 |
| `moodle/moodle` | Packagist | From 2.7.0 | 2.7.8 |
| `moodle/moodle` | Packagist | From 2.8.0 | 2.8.6 |
| `moodle/moodle` | Packagist | From 2.8.0 | 2.8.6 |

Products: Moodle Moodle.

## How do I fix CVE-2015-3181?

Upgrade moodle/moodle to a fixed version for your release line: 2.6.11, 2.7.8 or 2.8.6.

## Is CVE-2015-3181 being exploited?

There is no known exploitation of CVE-2015-3181 in the wild and no public exploit code.

## Other vulnerabilities in Moodle Moodle

- [CVE-2006-4935](https://insights.sbomify.com/CVE-2006-4935/): File upload in n/a (critical 10.0)
- [CVE-2006-4936](https://insights.sbomify.com/CVE-2006-4936/): Moodle does not properly validate module instance id (critical 10.0)
- [CVE-2004-2233](https://insights.sbomify.com/CVE-2004-2233/): Unknown "front page vulnerability with Moodle servers" for Moodle before 1.3.2 has unknown impact and attack vectors. (critical 10.0)
- [CVE-2004-2235](https://insights.sbomify.com/CVE-2004-2235/): Cross-site scripting in n/a (critical 10.0)
- [CVE-2004-2236](https://insights.sbomify.com/CVE-2004-2236/): Other in n/a (critical 10.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2015-3181 and fix it if it is affected.

What it is: CVE-2015-3181 is a medium-severity missing authorization vulnerability in Moodle Moodle, published on 1 Jun 2015. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2015-3181 in the wild and no public exploit code.

Affected packages and fixed versions:
- moodle/moodle (Packagist): affected all versions; fixed in 2.6.11
- moodle/moodle (Packagist): affected all versions; fixed in 2.6.11
- moodle/moodle (Packagist): affected from 2.7.0; fixed in 2.7.8
- moodle/moodle (Packagist): affected from 2.7.0; fixed in 2.7.8
- moodle/moodle (Packagist): affected from 2.8.0; fixed in 2.8.6
- moodle/moodle (Packagist): affected from 2.8.0; fixed in 2.8.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2015-3181/ (Markdown: https://insights.sbomify.com/CVE-2015-3181/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2015-3181
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2015-3181
- OSV: https://osv.dev/vulnerability/CVE-2015-3181

---
From sbomify Insights: https://insights.sbomify.com/CVE-2015-3181/
Summaries are generated and may contain mistakes; the official description above is the record.
