{"answers":{"affected":"2 open source packages ship an affected version, including org.apache.storm:storm. It affects 1 product.","exploited":"There is no known exploitation of CVE-2015-3188 in the wild and no public exploit code.","fix":"Upgrade org.apache.storm:storm to 0.10.0-beta1 or later.","what":"CVE-2015-3188 is a critical code injection vulnerability in n/a, published on 13 Jan 2017. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2015-3188 and fix it if it is affected.\n\nWhat it is: CVE-2015-3188 is a critical code injection vulnerability in n/a, published on 13 Jan 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2015-3188 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.apache.storm:storm (Maven): affected from 0.10.0-beta; fixed in 0.10.0-beta1\n- org.apache.storm:storm (Maven): affected from 0.10.0-beta; fixed in 0.10.0-beta1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2015-3188/ (Markdown: https://insights.sbomify.com/CVE-2015-3188/index.md)","id":"CVE-2015-3188","markdown":"https://insights.sbomify.com/CVE-2015-3188/index.md","name":"CVE-2015-3188","record":{"aliases":["GHSA-cg5h-q983-4rww"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Apache Storm UI daemon","requires_auth":"none","summary":"Remote attackers can execute arbitrary code on the Apache Storm UI daemon, requiring an upgrade to secure the distributed system.","user_interaction":"not_required","vuln_class":"code_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"redhat","cpe":[{"product":"storm","vendor":"apache"}],"cvss":{"score":9.8,"severity":"critical","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","version":"3.0"},"cwes":[{"id":"CWE-264","name":null}],"description":"The UI daemon in Apache Storm 0.10.0 before 0.10.0-beta1 allows remote attackers to execute arbitrary code via unspecified vectors.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Apache Storm remote code execution vulnerability","id":"CVE-2015-3188","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"code_injection","year":"2015"},"n_packages":2,"n_references":3,"next":{"headline":"Cloud Foundry Runtime has Weak Password Recovery Mechanism for Forgotten Password","id":"CVE-2015-3189"},"packages":[{"ecosystem":"Maven","fixed":["0.10.0-beta1"],"introduced":["0.10.0-beta"],"last_affected":[],"package":"org.apache.storm:storm","purl":null,"source":"GHSA-cg5h-q983-4rww"},{"ecosystem":"Maven","fixed":["0.10.0-beta1"],"introduced":["0.10.0-beta"],"last_affected":[],"package":"org.apache.storm:storm","purl":"pkg:maven/org.apache.storm/storm","source":"GHSA-cg5h-q983-4rww"}],"prev":{"headline":"Information disclosure in n/a","id":"CVE-2015-3187"},"products":["n/a"],"published":"2017-01-13","related":[{"cvss_score":9.8,"headline":"Shell Command Injection Vulnerability in Nimbus Thrift Server","id":"CVE-2021-38294","kev_date_added":null,"published":"2021-10-25"},{"cvss_score":9.8,"headline":"Unsafe Pre-Authentication Deserialization In Workers","id":"CVE-2021-40865","kev_date_added":null,"published":"2021-10-25"},{"cvss_score":9.8,"headline":"Deserialization of Untrusted Data in Apache Storm","id":"CVE-2018-11779","kev_date_added":null,"published":"2019-07-25"},{"cvss_score":8.8,"headline":"Apache Storm Client: RCE through Unsafe Deserialization via Kerberos TGT Credential Handling","id":"CVE-2026-35337","kev_date_added":null,"published":"2026-04-13"},{"cvss_score":8.8,"headline":"Code execution in org.apache.storm:storm-core","id":"CVE-2018-1331","kev_date_added":null,"published":"2018-07-10"},{"cvss_score":8.8,"headline":"Apache Storm it is possible for the owner of a topology to trick the supervisor to launch a worker as a different, non-root, user","id":"CVE-2017-9799","kev_date_added":null,"published":"2017-08-09"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-06","vendors":["n/a"]},"summary":"Remote attackers can execute arbitrary code on the Apache Storm UI daemon, requiring an upgrade to secure the distributed system.","url":"https://insights.sbomify.com/CVE-2015-3188/"}