# CVE-2015-3192: Pivotal Spring Framework DoS Attack with XML Input

> Remote attackers can cause denial of service via memory exhaustion using crafted XML files in Spring Framework when DTD processing is enabled.

- **Severity:** Medium 5.5 (`CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 12 Jul 2016
- **Updated:** 6 Aug 2024
- **Also known as:** CLSA-2026-1778546716, DEBIAN-CVE-2015-3192, GHSA-6v7w-535j-rq5m, MGASA-2015-0294, UBUNTU-CVE-2015-3192

## What is CVE-2015-3192?

CVE-2015-3192 is a medium-severity denial of service vulnerability in Fedoraproject Fedora, published on 12 Jul 2016. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

Pivotal Spring Framework before 3.2.14 and 4.x before 4.1.7 do not properly process inline DTD declarations when DTD is not entirely disabled, which allows remote attackers to cause a denial of service (memory consumption and out-of-memory errors) via a crafted XML file.

Weakness: CWE-119 (Improper Restriction of Operations within the Bounds of a Memory Buffer)

## Which versions are affected by CVE-2015-3192?

6 open source packages ship an affected version, including org.springframework:spring-web. It affects 3 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.springframework:spring-web` | Maven | All versions | 3.2.14 |
| `org.springframework:spring-web` | Maven | All versions | 3.2.14 |
| `org.springframework:spring-web` | Maven | From 4.0.0 | 4.1.7 |
| `org.springframework:spring-web` | Maven | From 4.0.0 | 4.1.7 |
| `org.springframework:spring-web` | Maven | From 5.0.0.RC2 | 5.0.0.RC3 |
| `org.springframework:spring-web` | Maven | From 5.0.0.RC2 | 5.0.0.RC3 |

Products: Fedoraproject Fedora, Pivotal Software Spring Framework, Vmware Spring Framework.

## How do I fix CVE-2015-3192?

Upgrade org.springframework:spring-web to a fixed version for your release line: 3.2.14, 4.1.7 or 5.0.0.RC3.

## Is CVE-2015-3192 being exploited?

There is no known exploitation of CVE-2015-3192 in the wild and no public exploit code.

## Other vulnerabilities in Fedoraproject Fedora

- [CVE-2024-4577](https://insights.sbomify.com/CVE-2024-4577/): PHP-CGI OS Command Injection (critical 9.8, exploited in the wild)
- [CVE-2021-39226](https://insights.sbomify.com/CVE-2021-39226/): Grafana Authentication Bypass (critical 9.8, exploited in the wild)
- [CVE-2019-5544](https://insights.sbomify.com/CVE-2019-5544/): VMware ESXi and Horizon DaaS OpenSLP Heap-Based Buffer Overflow (critical 9.8, exploited in the wild)
- [CVE-2024-4947](https://insights.sbomify.com/CVE-2024-4947/): Google Chromium V8 Type Confusion (critical 9.6, exploited in the wild)
- [CVE-2024-4671](https://insights.sbomify.com/CVE-2024-4671/): Google Chromium Visuals Use-After-Free (critical 9.6, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2015-3192 and fix it if it is affected.

What it is: CVE-2015-3192 is a medium-severity denial of service vulnerability in Fedoraproject Fedora, published on 12 Jul 2016. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2015-3192 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.springframework:spring-web (Maven): affected all versions; fixed in 3.2.14
- org.springframework:spring-web (Maven): affected all versions; fixed in 3.2.14
- org.springframework:spring-web (Maven): affected from 4.0.0; fixed in 4.1.7
- org.springframework:spring-web (Maven): affected from 4.0.0; fixed in 4.1.7
- org.springframework:spring-web (Maven): affected from 5.0.0.RC2; fixed in 5.0.0.RC3
- org.springframework:spring-web (Maven): affected from 5.0.0.RC2; fixed in 5.0.0.RC3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2015-3192/ (Markdown: https://insights.sbomify.com/CVE-2015-3192/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2015-3192
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2015-3192
- OSV: https://osv.dev/vulnerability/CVE-2015-3192

---
From sbomify Insights: https://insights.sbomify.com/CVE-2015-3192/
Summaries are generated and may contain mistakes; the official description above is the record.
