{"answers":{"affected":"6 open source packages ship an affected version, including kerberos and pykerberos. It affects 1 product.","exploited":"There is no known exploitation of CVE-2015-3206 in the wild and no public exploit code.","fix":"Apply the vendor's patch.","what":"CVE-2015-3206 is a high-severity authentication bypass vulnerability in n/a, published on 25 Aug 2017. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2015-3206 and fix it if it is affected.\n\nWhat it is: CVE-2015-3206 is a high-severity authentication bypass vulnerability in n/a, published on 25 Aug 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2015-3206 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- kerberos (PyPI): affected all versions up to 1.2.5; no fix listed\n- kerberos (PyPI): affected all versions up to 1.2.5; no fix listed\n- kerberos (PyPI): affected from 0.0; no fix listed\n- pykerberos (PyPI): affected all versions; fixed in 1.1.6\n- pykerberos (PyPI): affected all versions; fixed in 1.1.6\n- pykerberos (PyPI): affected all versions; fixed in 1.1.6\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2015-3206/ (Markdown: https://insights.sbomify.com/CVE-2015-3206/index.md)","id":"CVE-2015-3206","markdown":"https://insights.sbomify.com/CVE-2015-3206/index.md","name":"CVE-2015-3206","record":{"aliases":["DEBIAN-CVE-2015-3206","DLA-265-1","DLA-265-2","GHSA-mffc-9gx5-99g3","PYSEC-2017-49","PYSEC-2017-66"],"analysis":{"component_type":"library","fix_type":"patch","impacts":["denial_of_service","security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"Python Kerberos library","requires_auth":"none","summary":"Remote attackers can cause denial of service or bypass authentication via man-in-the-middle attacks due to lack of KDC authentication in python-kerberos.","user_interaction":"not_required","vuln_class":"auth_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"redhat","cpe":[{"product":"pykerberos","vendor":"apple"}],"cvss":{"score":8.1,"severity":"high","source":"nvd","vector":"CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H","version":"3.0"},"cwes":[{"id":"CWE-287","name":"Improper Authentication"}],"description":"The checkPassword function in python-kerberos does not authenticate the KDC it attempts to communicate with, which allows remote attackers to cause a denial of service (bad response), or have other unspecified impact by performing a man-in-the-middle attack.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"python-kerberos vulnerable to KDC spoofing attacks","id":"CVE-2015-3206","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"auth_bypass","year":"2015"},"n_packages":6,"n_references":5,"next":{"headline":"Insecure cookies in Openshift Origin","id":"CVE-2015-3207"},"packages":[{"ecosystem":"PyPI","fixed":[],"introduced":["0"],"last_affected":["1.2.5"],"package":"kerberos","purl":null,"source":"GHSA-mffc-9gx5-99g3"},{"ecosystem":"PyPI","fixed":[],"introduced":["0"],"last_affected":["1.2.5"],"package":"kerberos","purl":"pkg:pypi/kerberos","source":"GHSA-mffc-9gx5-99g3"},{"ecosystem":"PyPI","fixed":[],"introduced":["0.0"],"last_affected":[],"package":"kerberos","purl":"pkg:pypi/kerberos","source":"PYSEC-2017-49"},{"ecosystem":"PyPI","fixed":["1.1.6"],"introduced":["0"],"last_affected":[],"package":"pykerberos","purl":null,"source":"GHSA-mffc-9gx5-99g3"},{"ecosystem":"PyPI","fixed":["1.1.6"],"introduced":["0"],"last_affected":[],"package":"pykerberos","purl":"pkg:pypi/pykerberos","source":"GHSA-mffc-9gx5-99g3"},{"ecosystem":"PyPI","fixed":["1.1.6"],"introduced":["0"],"last_affected":[],"package":"pykerberos","purl":"pkg:pypi/pykerberos","source":"PYSEC-2017-66"}],"prev":{"headline":"Memory corruption in n/a","id":"CVE-2015-3205"},"products":["n/a"],"published":"2017-08-25","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-06","vendors":["n/a"]},"summary":"Remote attackers can cause denial of service or bypass authentication via man-in-the-middle attacks due to lack of KDC authentication in python-kerberos.","url":"https://insights.sbomify.com/CVE-2015-3206/"}