# CVE-2015-3206: python-kerberos vulnerable to KDC spoofing attacks

> Remote attackers can cause denial of service or bypass authentication via man-in-the-middle attacks due to lack of KDC authentication in python-kerberos.

- **Severity:** High 8.1 (`CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 25 Aug 2017
- **Updated:** 6 Aug 2024
- **Also known as:** DEBIAN-CVE-2015-3206, DLA-265-1, DLA-265-2, GHSA-mffc-9gx5-99g3, PYSEC-2017-49, PYSEC-2017-66

## What is CVE-2015-3206?

CVE-2015-3206 is a high-severity authentication bypass vulnerability in n/a, published on 25 Aug 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The checkPassword function in python-kerberos does not authenticate the KDC it attempts to communicate with, which allows remote attackers to cause a denial of service (bad response), or have other unspecified impact by performing a man-in-the-middle attack.

Weakness: CWE-287 (Improper Authentication)

## Which versions are affected by CVE-2015-3206?

6 open source packages ship an affected version, including kerberos and pykerberos. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `kerberos` | PyPI | All versions to 1.2.5 | None |
| `kerberos` | PyPI | All versions to 1.2.5 | None |
| `kerberos` | PyPI | From 0.0 | None |
| `pykerberos` | PyPI | All versions | 1.1.6 |
| `pykerberos` | PyPI | All versions | 1.1.6 |
| `pykerberos` | PyPI | All versions | 1.1.6 |

Products: Apple Pykerberos.

## How do I fix CVE-2015-3206?

Apply the vendor's patch.

## Is CVE-2015-3206 being exploited?

There is no known exploitation of CVE-2015-3206 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2015-3206 and fix it if it is affected.

What it is: CVE-2015-3206 is a high-severity authentication bypass vulnerability in n/a, published on 25 Aug 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2015-3206 in the wild and no public exploit code.

Affected packages and fixed versions:
- kerberos (PyPI): affected all versions up to 1.2.5; no fix listed
- kerberos (PyPI): affected all versions up to 1.2.5; no fix listed
- kerberos (PyPI): affected from 0.0; no fix listed
- pykerberos (PyPI): affected all versions; fixed in 1.1.6
- pykerberos (PyPI): affected all versions; fixed in 1.1.6
- pykerberos (PyPI): affected all versions; fixed in 1.1.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2015-3206/ (Markdown: https://insights.sbomify.com/CVE-2015-3206/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2015-3206
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2015-3206
- OSV: https://osv.dev/vulnerability/CVE-2015-3206

---
From sbomify Insights: https://insights.sbomify.com/CVE-2015-3206/
Summaries are generated and may contain mistakes; the official description above is the record.
