{"answers":{"affected":"3 open source packages ship an affected version, including horizon. It affects 3 products.","exploited":"There is no known exploitation of CVE-2015-3219 in the wild and no public exploit code.","fix":"Upgrade horizon to 8.0.0a0 or later.","what":"CVE-2015-3219 is a medium-severity cross-site scripting vulnerability in Debian Debian Linux, published on 20 Aug 2015. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2015-3219 and fix it if it is affected.\n\nWhat it is: CVE-2015-3219 is a medium-severity cross-site scripting vulnerability in Debian Debian Linux, published on 20 Aug 2015. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2015-3219 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- horizon (PyPI): affected all versions; fixed in 8.0.0a0\n- horizon (PyPI): affected all versions; fixed in 8.0.0a0\n- horizon (PyPI): affected all versions; fixed in 8.0.0a0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2015-3219/ (Markdown: https://insights.sbomify.com/CVE-2015-3219/index.md)","id":"CVE-2015-3219","markdown":"https://insights.sbomify.com/CVE-2015-3219/index.md","name":"CVE-2015-3219","record":{"aliases":["DEBIAN-CVE-2015-3219","GHSA-rhjj-f6gq-6gx2","PYSEC-2015-40"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution","security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"OpenStack Dashboard","requires_auth":"low_privilege","summary":"Remote attackers can inject arbitrary web script via heat template descriptions in OpenStack Dashboard, requiring user interaction to execute.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"redhat","cpe":[{"product":"debian_linux","vendor":"debian"},{"product":"horizon","vendor":"openstack"},{"product":"solaris","vendor":"oracle"}],"cvss":{"score":4.3,"severity":"medium","source":"nvd","vector":"AV:N/AC:M/Au:N/C:N/I:P/A:N","version":"2.0"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"Cross-site scripting (XSS) vulnerability in the Orchestration/Stack section in OpenStack Dashboard (Horizon) 2014.2 before 2014.2.4 and 2015.1.x before 2015.1.1 allows remote attackers to inject arbitrary web script or HTML via the description parameter in a heat template, which is not properly handled in the help_text attribute in the Field class.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"OpenStack Dashboard (Horizon) Cross-site scripting (XSS) vulnerability","id":"CVE-2015-3219","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":"debian:debian_linux","products":["debian:debian_linux","oracle:solaris"],"type":"xss","year":"2015"},"n_packages":3,"n_references":7,"next":{"headline":"tlslite remote denial of service vulnerability","id":"CVE-2015-3220"},"packages":[{"ecosystem":"PyPI","fixed":["8.0.0a0"],"introduced":["0"],"last_affected":[],"package":"horizon","purl":null,"source":"GHSA-rhjj-f6gq-6gx2"},{"ecosystem":"PyPI","fixed":["8.0.0a0"],"introduced":["0"],"last_affected":[],"package":"horizon","purl":"pkg:pypi/horizon","source":"GHSA-rhjj-f6gq-6gx2"},{"ecosystem":"PyPI","fixed":["8.0.0a0"],"introduced":["0"],"last_affected":[],"package":"horizon","purl":"pkg:pypi/horizon","source":"PYSEC-2015-40"}],"prev":{"headline":"Null dereference in n/a","id":"CVE-2015-3218"},"products":["n/a"],"published":"2015-08-20","related":[{"cvss_score":10,"headline":"ProFTPD Improper Access Control","id":"CVE-2015-3306","kev_date_added":"2026-10-08","published":"2015-05-18"},{"cvss_score":9.9,"headline":"RoundCube Webmail Deserialization of Untrusted Data","id":"CVE-2025-49113","kev_date_added":"2026-02-20","published":"2025-06-02"},{"cvss_score":9.8,"headline":"GNU InetUtils Argument Injection","id":"CVE-2026-24061","kev_date_added":"2026-01-26","published":"2026-01-21"},{"cvss_score":9.8,"headline":"Linux Kernel Improper Check for Unusual or Exceptional Conditions","id":"CVE-2025-39682","kev_date_added":"2026-09-18","published":"2025-09-05"},{"cvss_score":9.8,"headline":"Mozilla Firefox Use-After-Free","id":"CVE-2024-9680","kev_date_added":"2024-10-15","published":"2024-10-09"},{"cvss_score":9.8,"headline":"RARLAB UnRAR Directory Traversal","id":"CVE-2022-30333","kev_date_added":"2022-08-09","published":"2022-05-09"},{"cvss_score":9.8,"headline":"Roundcube Webmail SQL Injection","id":"CVE-2021-44026","kev_date_added":"2023-06-22","published":"2021-11-19"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-06","vendors":["n/a"]},"summary":"Remote attackers can inject arbitrary web script via heat template descriptions in OpenStack Dashboard, requiring user interaction to execute.","url":"https://insights.sbomify.com/CVE-2015-3219/"}