# CVE-2015-3219: OpenStack Dashboard (Horizon) Cross-site scripting (XSS) vulnerability

> Remote attackers can inject arbitrary web script via heat template descriptions in OpenStack Dashboard, requiring user interaction to execute.

- **Severity:** Medium 4.3 (`AV:N/AC:M/Au:N/C:N/I:P/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 20 Aug 2015
- **Updated:** 6 Aug 2024
- **Also known as:** DEBIAN-CVE-2015-3219, GHSA-rhjj-f6gq-6gx2, PYSEC-2015-40

## What is CVE-2015-3219?

CVE-2015-3219 is a medium-severity cross-site scripting vulnerability in Debian Debian Linux, published on 20 Aug 2015. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

Cross-site scripting (XSS) vulnerability in the Orchestration/Stack section in OpenStack Dashboard (Horizon) 2014.2 before 2014.2.4 and 2015.1.x before 2015.1.1 allows remote attackers to inject arbitrary web script or HTML via the description parameter in a heat template, which is not properly handled in the help_text attribute in the Field class.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2015-3219?

3 open source packages ship an affected version, including horizon. It affects 3 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `horizon` | PyPI | All versions | 8.0.0a0 |
| `horizon` | PyPI | All versions | 8.0.0a0 |
| `horizon` | PyPI | All versions | 8.0.0a0 |

Products: Debian Debian Linux, Openstack Horizon, Oracle Solaris.

## How do I fix CVE-2015-3219?

Upgrade horizon to 8.0.0a0 or later.

## Is CVE-2015-3219 being exploited?

There is no known exploitation of CVE-2015-3219 in the wild and no public exploit code.

## Other vulnerabilities in Debian Debian Linux

- [CVE-2015-3306](https://insights.sbomify.com/CVE-2015-3306/): ProFTPD Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2025-49113](https://insights.sbomify.com/CVE-2025-49113/): RoundCube Webmail Deserialization of Untrusted Data (critical 9.9, exploited in the wild)
- [CVE-2026-24061](https://insights.sbomify.com/CVE-2026-24061/): GNU InetUtils Argument Injection (critical 9.8, exploited in the wild)
- [CVE-2025-39682](https://insights.sbomify.com/CVE-2025-39682/): Linux Kernel Improper Check for Unusual or Exceptional Conditions (critical 9.8, exploited in the wild)
- [CVE-2024-9680](https://insights.sbomify.com/CVE-2024-9680/): Mozilla Firefox Use-After-Free (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2015-3219 and fix it if it is affected.

What it is: CVE-2015-3219 is a medium-severity cross-site scripting vulnerability in Debian Debian Linux, published on 20 Aug 2015. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2015-3219 in the wild and no public exploit code.

Affected packages and fixed versions:
- horizon (PyPI): affected all versions; fixed in 8.0.0a0
- horizon (PyPI): affected all versions; fixed in 8.0.0a0
- horizon (PyPI): affected all versions; fixed in 8.0.0a0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2015-3219/ (Markdown: https://insights.sbomify.com/CVE-2015-3219/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2015-3219
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2015-3219
- OSV: https://osv.dev/vulnerability/CVE-2015-3219

---
From sbomify Insights: https://insights.sbomify.com/CVE-2015-3219/
Summaries are generated and may contain mistakes; the official description above is the record.
