{"answers":{"affected":"3 open source packages ship an affected version, including tlslite. It affects 1 product.","exploited":"There is no known exploitation of CVE-2015-3220 in the wild and no public exploit code.","fix":"Upgrade tlslite to 0.4.9 or later.","what":"CVE-2015-3220 is a high-severity denial of service vulnerability in n/a, published on 13 Jun 2017. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2015-3220 and fix it if it is affected.\n\nWhat it is: CVE-2015-3220 is a high-severity denial of service vulnerability in n/a, published on 13 Jun 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2015-3220 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- tlslite (PyPI): affected all versions; fixed in 0.4.9\n- tlslite (PyPI): affected all versions; fixed in 0.4.9\n- tlslite (PyPI): affected all versions; fixed in 0.4.9\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2015-3220/ (Markdown: https://insights.sbomify.com/CVE-2015-3220/index.md)","id":"CVE-2015-3220","markdown":"https://insights.sbomify.com/CVE-2015-3220/index.md","name":"CVE-2015-3220","record":{"aliases":["GHSA-4749-p7rx-8jjj","PYSEC-2017-96"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Python TLS library","requires_auth":"none","summary":"Remote attackers can cause a denial of service by triggering a runtime exception and process crash in the tlslite library.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"redhat","cpe":[{"product":"tlslite","vendor":"tlslite_project"}],"cvss":{"score":7.5,"severity":"high","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","version":"3.0"},"cwes":[{"id":"CWE-119","name":"Improper Restriction of Operations within the Bounds of a Memory Buffer"}],"description":"The tlslite library before 0.4.9 for Python allows remote attackers to trigger a denial of service (runtime exception and process crash).","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"tlslite remote denial of service vulnerability","id":"CVE-2015-3220","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"denial_of_service","year":"2015"},"n_packages":3,"n_references":3,"next":{"headline":"OpenStack Neutron Improper Input Validation vulnerability","id":"CVE-2015-3221"},"packages":[{"ecosystem":"PyPI","fixed":["0.4.9"],"introduced":["0"],"last_affected":[],"package":"tlslite","purl":null,"source":"GHSA-4749-p7rx-8jjj"},{"ecosystem":"PyPI","fixed":["0.4.9"],"introduced":["0"],"last_affected":[],"package":"tlslite","purl":"pkg:pypi/tlslite","source":"GHSA-4749-p7rx-8jjj"},{"ecosystem":"PyPI","fixed":["0.4.9"],"introduced":["0"],"last_affected":[],"package":"tlslite","purl":"pkg:pypi/tlslite","source":"PYSEC-2017-96"}],"prev":{"headline":"OpenStack Dashboard (Horizon) Cross-site scripting (XSS) vulnerability","id":"CVE-2015-3219"},"products":["n/a"],"published":"2017-06-13","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-06","vendors":["n/a"]},"summary":"Remote attackers can cause a denial of service by triggering a runtime exception and process crash in the tlslite library.","url":"https://insights.sbomify.com/CVE-2015-3220/"}