# CVE-2015-3220: tlslite remote denial of service vulnerability

> Remote attackers can cause a denial of service by triggering a runtime exception and process crash in the tlslite library.

- **Severity:** High 7.5 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 13 Jun 2017
- **Updated:** 6 Aug 2024
- **Also known as:** GHSA-4749-p7rx-8jjj, PYSEC-2017-96

## What is CVE-2015-3220?

CVE-2015-3220 is a high-severity denial of service vulnerability in n/a, published on 13 Jun 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The tlslite library before 0.4.9 for Python allows remote attackers to trigger a denial of service (runtime exception and process crash).

Weakness: CWE-119 (Improper Restriction of Operations within the Bounds of a Memory Buffer)

## Which versions are affected by CVE-2015-3220?

3 open source packages ship an affected version, including tlslite. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `tlslite` | PyPI | All versions | 0.4.9 |
| `tlslite` | PyPI | All versions | 0.4.9 |
| `tlslite` | PyPI | All versions | 0.4.9 |

Products: Tlslite Project Tlslite.

## How do I fix CVE-2015-3220?

Upgrade tlslite to 0.4.9 or later.

## Is CVE-2015-3220 being exploited?

There is no known exploitation of CVE-2015-3220 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2015-3220 and fix it if it is affected.

What it is: CVE-2015-3220 is a high-severity denial of service vulnerability in n/a, published on 13 Jun 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2015-3220 in the wild and no public exploit code.

Affected packages and fixed versions:
- tlslite (PyPI): affected all versions; fixed in 0.4.9
- tlslite (PyPI): affected all versions; fixed in 0.4.9
- tlslite (PyPI): affected all versions; fixed in 0.4.9

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2015-3220/ (Markdown: https://insights.sbomify.com/CVE-2015-3220/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2015-3220
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2015-3220
- OSV: https://osv.dev/vulnerability/CVE-2015-3220

---
From sbomify Insights: https://insights.sbomify.com/CVE-2015-3220/
Summaries are generated and may contain mistakes; the official description above is the record.
