# CVE-2015-3221: OpenStack Neutron Improper Input Validation vulnerability

> Authenticated users can crash the L2 agent by adding invalid address pairs when using the IPTables firewall driver.

- **Severity:** Medium 4.0 (`AV:N/AC:L/Au:S/C:N/I:N/A:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 26 Aug 2015
- **Updated:** 6 Aug 2024
- **Also known as:** DEBIAN-CVE-2015-3221, GHSA-wf44-4mgj-rwvx, PYSEC-2026-856, RHSA-2015:1680

## What is CVE-2015-3221?

CVE-2015-3221 is a medium-severity denial of service vulnerability in n/a, published on 26 Aug 2015. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

OpenStack Neutron before 2014.2.4 (juno) and 2015.1.x before 2015.1.1 (kilo), when using the IPTables firewall driver, allows remote authenticated users to cause a denial of service (L2 agent crash) by adding an address pair that is rejected by the ipset tool.

Weakness: CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2015-3221?

5 open source packages ship an affected version, including neutron. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `neutron` | PyPI | All versions | 2014.2.4, 2015.1.1 |
| `neutron` | PyPI | From 2000 | 2014.2.4 |
| `neutron` | PyPI | From 2000 | 2014.2.4 |
| `neutron` | PyPI | From 2015.1.0 | 2015.1.1 |
| `neutron` | PyPI | From 2015.1.0 | 2015.1.1 |
| `openstack-neutron` | Red Hat:openstack:6::el7 | All versions | 0:2014.2.3-9.el7ost |
| `openstack-neutron-bigswitch` | Red Hat:openstack:6::el7 | All versions | 0:2014.2.3-9.el7ost |
| `openstack-neutron-brocade` | Red Hat:openstack:6::el7 | All versions | 0:2014.2.3-9.el7ost |
| `openstack-neutron-cisco` | Red Hat:openstack:6::el7 | All versions | 0:2014.2.3-9.el7ost |
| `openstack-neutron-common` | Red Hat:openstack:6::el7 | All versions | 0:2014.2.3-9.el7ost |
| `openstack-neutron-embrane` | Red Hat:openstack:6::el7 | All versions | 0:2014.2.3-9.el7ost |
| `openstack-neutron-hyperv` | Red Hat:openstack:6::el7 | All versions | 0:2014.2.3-9.el7ost |
| `openstack-neutron-ibm` | Red Hat:openstack:6::el7 | All versions | 0:2014.2.3-9.el7ost |
| `openstack-neutron-linuxbridge` | Red Hat:openstack:6::el7 | All versions | 0:2014.2.3-9.el7ost |
| `openstack-neutron-mellanox` | Red Hat:openstack:6::el7 | All versions | 0:2014.2.3-9.el7ost |
| `openstack-neutron-metaplugin` | Red Hat:openstack:6::el7 | All versions | 0:2014.2.3-9.el7ost |
| `openstack-neutron-metering-agent` | Red Hat:openstack:6::el7 | All versions | 0:2014.2.3-9.el7ost |
| `openstack-neutron-midonet` | Red Hat:openstack:6::el7 | All versions | 0:2014.2.3-9.el7ost |
| `openstack-neutron-ml2` | Red Hat:openstack:6::el7 | All versions | 0:2014.2.3-9.el7ost |
| `openstack-neutron-nec` | Red Hat:openstack:6::el7 | All versions | 0:2014.2.3-9.el7ost |
| `openstack-neutron-nuage` | Red Hat:openstack:6::el7 | All versions | 0:2014.2.3-9.el7ost |
| `openstack-neutron-ofagent` | Red Hat:openstack:6::el7 | All versions | 0:2014.2.3-9.el7ost |
| `openstack-neutron-oneconvergence-nvsd` | Red Hat:openstack:6::el7 | All versions | 0:2014.2.3-9.el7ost |
| `openstack-neutron-opencontrail` | Red Hat:openstack:6::el7 | All versions | 0:2014.2.3-9.el7ost |
| `openstack-neutron-openvswitch` | Red Hat:openstack:6::el7 | All versions | 0:2014.2.3-9.el7ost |
| `openstack-neutron-plumgrid` | Red Hat:openstack:6::el7 | All versions | 0:2014.2.3-9.el7ost |
| `openstack-neutron-ryu` | Red Hat:openstack:6::el7 | All versions | 0:2014.2.3-9.el7ost |
| `openstack-neutron-sriov-nic-agent` | Red Hat:openstack:6::el7 | All versions | 0:2014.2.3-9.el7ost |
| `openstack-neutron-vmware` | Red Hat:openstack:6::el7 | All versions | 0:2014.2.3-9.el7ost |
| `openstack-neutron-vpn-agent` | Red Hat:openstack:6::el7 | All versions | 0:2014.2.3-9.el7ost |
| `python-neutron` | Red Hat:openstack:6::el7 | All versions | 0:2014.2.3-9.el7ost |

Products: Openstack Neutron.

## How do I fix CVE-2015-3221?

Upgrade neutron to a fixed version for your release line: 2014.2.4 or 2015.1.1.

## Is CVE-2015-3221 being exploited?

There is no known exploitation of CVE-2015-3221 in the wild and no public exploit code.

Public exploit code:

- GeniXCMS 0.0.3 - Cross-Site Scripting (exploitdb)

## Other vulnerabilities in n/a

- [CVE-2021-38598](https://insights.sbomify.com/CVE-2021-38598/): OpenStack Neutron vulnerable to hardware address impersonation (critical 9.1)
- [CVE-2015-8914](https://insights.sbomify.com/CVE-2015-8914/): OpenStack Neutron allows remote attackers to bypass an intended ICMPv6-spoofing protection mechanism (critical 9.1)
- [CVE-2016-5362](https://insights.sbomify.com/CVE-2016-5362/): OpenStack Neutron allows remote attackers to bypass an intended DHCP-spoofing protection mechanism (high 8.2)
- [CVE-2016-5363](https://insights.sbomify.com/CVE-2016-5363/): OpenStack Neutron Intended MAC-spoofing protection mechanism bypass (high 8.2)
- [CVE-2014-3632](https://insights.sbomify.com/CVE-2014-3632/): Privilege escalation in n/a (high 7.6)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2015-3221 and fix it if it is affected.

What it is: CVE-2015-3221 is a medium-severity denial of service vulnerability in n/a, published on 26 Aug 2015. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2015-3221 in the wild and no public exploit code.

Affected packages and fixed versions:
- neutron (PyPI): affected all versions; fixed in 2014.2.4, 2015.1.1
- neutron (PyPI): affected from 2000; fixed in 2014.2.4
- neutron (PyPI): affected from 2000; fixed in 2014.2.4
- neutron (PyPI): affected from 2015.1.0; fixed in 2015.1.1
- neutron (PyPI): affected from 2015.1.0; fixed in 2015.1.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2015-3221/ (Markdown: https://insights.sbomify.com/CVE-2015-3221/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2015-3221
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2015-3221
- OSV: https://osv.dev/vulnerability/CVE-2015-3221

---
From sbomify Insights: https://insights.sbomify.com/CVE-2015-3221/
Summaries are generated and may contain mistakes; the official description above is the record.
