# CVE-2015-3224: Web Console (Ruby gem) contains whitelisted_ips bypass

> Attackers can bypass IP whitelisting in Web Console by spoofing X-Forwarded-For headers, gaining unauthorized access to the debugging console.

- **Severity:** Medium 4.3 (`AV:N/AC:M/Au:N/C:N/I:P/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 26 Jul 2015
- **Updated:** 6 Aug 2024
- **Also known as:** GHSA-67j6-xv27-w6ww, openSUSE-SU-2024:11356-1, openSUSE-SU-2024:13172-1, openSUSE-SU-2024:14179-1, openSUSE-SU-2025:15129-1, openSUSE-SU-2026:10367-1

## What is CVE-2015-3224?

CVE-2015-3224 is a medium-severity vulnerability in n/a, published on 26 Jul 2015. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

request.rb in Web Console before 2.1.3, as used with Ruby on Rails 3.x and 4.x, does not properly restrict the use of X-Forwarded-For headers in determining a client's IP address, which allows remote attackers to bypass the whitelisted_ips protection mechanism via a crafted request.

Weakness: CWE-284 (Improper Access Control)

## Which versions are affected by CVE-2015-3224?

2 open source packages ship an affected version, including web-console. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `web-console` | RubyGems | All versions | 2.1.3 |
| `web-console` | RubyGems | All versions | 2.1.3 |
| `ruby3.2-rubygem-web-console` | openSUSE:Tumbleweed | All versions | 4.2.0-1.9 |
| `rubygem-web-console` | openSUSE:Tumbleweed | All versions | 4.2.1-1.5 |
| `rubygem-web-console` | openSUSE:Tumbleweed | All versions | 4.2.1-1.7 |
| `rubygem-web-console` | openSUSE:Tumbleweed | All versions | 4.2.1-1.9 |

Products: Rubyonrails Web Console.

## How do I fix CVE-2015-3224?

Upgrade web-console to 2.1.3 or later.

## Is CVE-2015-3224 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2015-3224 exists.

Public exploit code:

- Ruby on Rails Web Console (v2) Whitelist Bypass Code Execution implementation in Python (github_poc): https://github.com/0xEval/cve-2015-3224
- Modification of Metasploit module for RCE in Ruby-On-Rails Console CVE-2015-3224 (github_poc): https://github.com/0x00-0x00/CVE-2015-3224
- CVE-2015-3224 Exploit - Rails Web Console RCE (github_poc): https://github.com/SQU4NCH/CVE-2015-3224
- Ruby on Rails 4.0.x/4.1.x/4.2.x (Web Console v2) - Whitelist Bypass Code Execution (Metasploit) (exploitdb)
- Ruby on Rails Web Console (v2) Whitelist Bypass Code Execution (metasploit)
- CVE-2015-3224  (github_poc): https://github.com/n000xy/CVE-2015-3224-

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2015-3224 and fix it if it is affected.

What it is: CVE-2015-3224 is a medium-severity vulnerability in n/a, published on 26 Jul 2015. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2015-3224 exists.

Affected packages and fixed versions:
- web-console (RubyGems): affected all versions; fixed in 2.1.3
- web-console (RubyGems): affected all versions; fixed in 2.1.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2015-3224/ (Markdown: https://insights.sbomify.com/CVE-2015-3224/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2015-3224
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2015-3224
- OSV: https://osv.dev/vulnerability/CVE-2015-3224

---
From sbomify Insights: https://insights.sbomify.com/CVE-2015-3224/
Summaries are generated and may contain mistakes; the official description above is the record.
