CVE-2015-3225 Rack vulnerable to Denial of Service via large parameter depth request

Medium 5.0 Published Updated

Remote attackers can cause a denial of service via SystemStackError by sending requests with excessive parameter depth in the Rack library.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2015-3225?

CVE-2015-3225 is a medium-severity denial of service vulnerability in Debian Debian Linux, published on 26 Jul 2015. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

lib/rack/utils.rb in Rack before 1.5.4 and 1.6.x before 1.6.2, as used with Ruby on Rails 3.x and 4.x and other products, allows remote attackers to cause a denial of service (SystemStackError) via a request with a large parameter depth.

Weakness: CWE-19

Which versions are affected by CVE-2015-3225?

6 open source packages ship an affected version, including rack. It affects 3 products.

PackageAffectedFixed in
rack RubyGemsFrom 1.4.01.4.6
rack RubyGemsFrom 1.4.01.4.6
rack RubyGemsFrom 1.5.01.5.4
rack RubyGemsFrom 1.5.01.5.4
rack RubyGemsFrom 1.6.01.6.2
rack RubyGemsFrom 1.6.01.6.2
Linux distribution packages (13)
pcs Red Hat:enterprise_linux:7::serverAll versions0:0.9.143-15.el7
pcs-debuginfo Red Hat:enterprise_linux:7::serverAll versions0:0.9.143-15.el7
rubygem-rack-1_4 SUSE:Enterprise Storage 1.0All versions1.4.5-8.10
rubygem-rack-1_4 SUSE:Enterprise Storage 2All versions1.4.5-8.10
rubygem-rack SUSE:Lifecycle Management Server 1.3All versions1.1.6-0.11.2
rubygem-rack-1_4 SUSE:Lifecycle Management Server 1.3All versions1.4.5-0.7.3
rubygem-rack-1_4 SUSE:Linux Enterprise Module for Containers 12All versions1.4.5-8.10
rubygem-rack SUSE:Linux Enterprise Software Development Kit 11 SP3All versions1.1.6-0.11.2
rubygem-rack-1_4 SUSE:Linux Enterprise Software Development Kit 11 SP3All versions1.4.5-0.7.3
rubygem-rack-1_4 SUSE:Linux Enterprise Software Development Kit 11 SP4All versions1.4.5-0.7.3
rubygem-rack SUSE:OpenStack Cloud 5All versions1.5.2-9.6
rubygem-rack-1_4 SUSE:Studio Onsite 1.3All versions1.4.5-0.7.3
rubygem-rack-1_4 SUSE:WebYast 1.3All versions1.4.5-0.7.3

Products include Debian Debian Linux, Opensuse Opensuse, Rack Project Rack.

How do I fix CVE-2015-3225?

Upgrade rack to a fixed version for your release line: 1.4.6, 1.5.4 or 1.6.2.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2015-3225 being exploited?

There is no known exploitation of CVE-2015-3225 in the wild and no public exploit code.

All Debian Debian Linux vulnerabilities

Sources

Also known as DEBIAN-CVE-2015-3225, DLA-254-1, DSA-3322-1, GHSA-rgr4-9jh5-j4j6, MGASA-2015-0346, RHSA-2015:2290 and 4 more.

Is CVE-2015-3225 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free