CVE-2015-3226 activesupport Cross-site Scripting vulnerability

Medium 4.3 Published Updated

Remote attackers can inject arbitrary web script or HTML via crafted Hashes in Ruby on Rails JSON encoding, requiring user interaction to execute.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2015-3226?

CVE-2015-3226 is a medium-severity cross-site scripting vulnerability in Rubyonrails Rails, published on 26 Jul 2015. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

Official description

Cross-site scripting (XSS) vulnerability in json/encoding.rb in Active Support in Ruby on Rails 3.x and 4.1.x before 4.1.11 and 4.2.x before 4.2.2 allows remote attackers to inject arbitrary web script or HTML via a crafted Hash that is mishandled during JSON encoding.

Weakness: CWE-79

Which versions are affected by CVE-2015-3226?

4 open source packages ship an affected version, including activesupport. It affects 2 products.

PackageAffectedFixed in
activesupport RubyGemsFrom 4.1.04.1.11
activesupport RubyGemsFrom 4.1.04.1.11
activesupport RubyGemsFrom 4.2.04.2.2
activesupport RubyGemsFrom 4.2.04.2.2

Products include Rubyonrails Rails, Rubyonrails Ruby on Rails.

How do I fix CVE-2015-3226?

Upgrade activesupport to a fixed version for your release line: 4.1.11 or 4.2.2.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2015-3226 being exploited?

There is no known exploitation of CVE-2015-3226 in the wild and no public exploit code.

All Rubyonrails Rails vulnerabilities

Sources

Also known as DEBIAN-CVE-2015-3226, GHSA-vxvp-4xwc-jpp6.

Is CVE-2015-3226 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free