CVE-2015-3227 activesupport vulnerable to Denial of Service via large XML document depth
Remote attackers can cause denial of service via large XML documents in Active Support when JDOM or REXML is enabled.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2015-3227?
CVE-2015-3227 is a medium-severity denial of service vulnerability in Opensuse Opensuse, published on 26 Jul 2015. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
The (1) jdom.rb and (2) rexml.rb components in Active Support in Ruby on Rails before 4.1.11 and 4.2.x before 4.2.2, when JDOM or REXML is enabled, allow remote attackers to cause a denial of service (SystemStackError) via a large XML document depth.
Which versions are affected by CVE-2015-3227?
6 open source packages ship an affected version, including activesupport. It affects 2 products.
| Package | Affected | Fixed in |
|---|---|---|
activesupport RubyGems | All versions | 3.2.22 |
activesupport RubyGems | All versions | 3.2.22 |
activesupport RubyGems | From 4.0.0.beta1 | 4.1.11 |
activesupport RubyGems | From 4.0.0.beta1 | 4.1.11 |
activesupport RubyGems | From 4.2.0.beta1 | 4.2.2 |
activesupport RubyGems | From 4.2.0.beta1 | 4.2.2 |
Linux distribution packages (5)
rubygem-activesupport-3_2 SUSE:Lifecycle Management Server 1.3 | All versions | 3.2.12-0.14.3 |
rubygem-activesupport-3_2 SUSE:Linux Enterprise Software Development Kit 11 SP3 | All versions | 3.2.12-0.14.3 |
rubygem-activesupport-3_2 SUSE:Linux Enterprise Software Development Kit 11 SP4 | All versions | 3.2.12-0.14.3 |
rubygem-activesupport-3_2 SUSE:Studio Onsite 1.3 | All versions | 3.2.12-0.14.3 |
rubygem-activesupport-3_2 SUSE:WebYast 1.3 | All versions | 3.2.12-0.14.3 |
Products include Opensuse Opensuse, Rubyonrails Rails.
How do I fix CVE-2015-3227?
Upgrade activesupport to a fixed version for your release line: 3.2.22, 4.1.11 or 4.2.2.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2015-3227 being exploited?
There is no known exploitation of CVE-2015-3227 in the wild and no public exploit code.
Other vulnerabilities in Opensuse Opensuse
Sources
Also known as DEBIAN-CVE-2015-3227, DLA-603-1, GHSA-j96r-xvjq-r9pg, SUSE-SU-2016:0047-1.