{"answers":{"affected":"It affects 1 product.","exploited":"There is no known exploitation of CVE-2015-3228 in the wild and no public exploit code.","fix":"Upgrade to a fixed version.","what":"CVE-2015-3228 is a medium-severity vulnerability in n/a, published on 11 Aug 2015. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2015-3228 and fix it if it is affected.\n\nWhat it is: CVE-2015-3228 is a medium-severity vulnerability in n/a, published on 11 Aug 2015. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2015-3228 in the wild and no public exploit code.\n\nAffected product: n/a. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2015-3228/ (Markdown: https://insights.sbomify.com/CVE-2015-3228/index.md)","id":"CVE-2015-3228","markdown":"https://insights.sbomify.com/CVE-2015-3228/index.md","name":"CVE-2015-3228","record":{"aliases":["DEBIAN-CVE-2015-3228","DLA-280-1","DSA-3326-1","GHSA-jf9j-9gh2-gp45","MGASA-2015-0308","SUSE-SU-2016:0884-1","UBUNTU-CVE-2015-3228","USN-2697-1"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Ghostscript library","requires_auth":"none","summary":"Remote attackers can cause a denial of service via a crafted PostScript file due to an integer overflow in Ghostscript.","user_interaction":"required","vuln_class":"integer_overflow"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"redhat","cpe":[{"product":"afpl_ghostscript","vendor":"artifex"}],"cvss":{"score":6.8,"severity":"medium","source":"nvd","vector":"AV:N/AC:M/Au:N/C:P/I:P/A:P","version":"2.0"},"cwes":[{"id":"CWE-189","name":null}],"description":"Integer overflow in the gs_heap_alloc_bytes function in base/gsmalloc.c in Ghostscript 9.15 and earlier allows remote attackers to cause a denial of service (crash) via a crafted Postscript (ps) file, as demonstrated by using the ps2pdf command, which triggers an out-of-bounds read or write.","ecosystems":["SUSE:Linux Enterprise Desktop 12","SUSE:Linux Enterprise Desktop 12 SP1","SUSE:Linux Enterprise Server 12","SUSE:Linux Enterprise Server 12 SP1","SUSE:Linux Enterprise Server for SAP Applications 12","SUSE:Linux Enterprise Server for SAP Applications 12 SP1","SUSE:Linux Enterprise Software Development Kit 12","SUSE:Linux Enterprise Software Development Kit 12 SP1"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Integer overflow in n/a","id":"CVE-2015-3228","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"integer_overflow","year":"2015"},"n_packages":8,"n_references":11,"next":{"headline":"Security feature bypass in n/a","id":"CVE-2015-3229"},"packages":[{"ecosystem":"SUSE:Linux Enterprise Desktop 12","fixed":["9.15-6.5"],"introduced":["0"],"last_affected":[],"package":"ghostscript","purl":"pkg:rpm/suse/ghostscript\u0026distro=SUSE%20Linux%20Enterprise%20Desktop%2012","source":"SUSE-SU-2016:0884-1"},{"ecosystem":"SUSE:Linux Enterprise Desktop 12 SP1","fixed":["9.15-6.5"],"introduced":["0"],"last_affected":[],"package":"ghostscript","purl":"pkg:rpm/suse/ghostscript\u0026distro=SUSE%20Linux%20Enterprise%20Desktop%2012%20SP1","source":"SUSE-SU-2016:0884-1"},{"ecosystem":"SUSE:Linux Enterprise Server 12","fixed":["9.15-6.5"],"introduced":["0"],"last_affected":[],"package":"ghostscript","purl":"pkg:rpm/suse/ghostscript\u0026distro=SUSE%20Linux%20Enterprise%20Server%2012","source":"SUSE-SU-2016:0884-1"},{"ecosystem":"SUSE:Linux Enterprise Server 12 SP1","fixed":["9.15-6.5"],"introduced":["0"],"last_affected":[],"package":"ghostscript","purl":"pkg:rpm/suse/ghostscript\u0026distro=SUSE%20Linux%20Enterprise%20Server%2012%20SP1","source":"SUSE-SU-2016:0884-1"},{"ecosystem":"SUSE:Linux Enterprise Server for SAP Applications 12","fixed":["9.15-6.5"],"introduced":["0"],"last_affected":[],"package":"ghostscript","purl":"pkg:rpm/suse/ghostscript\u0026distro=SUSE%20Linux%20Enterprise%20Server%20for%20SAP%20Applications%2012","source":"SUSE-SU-2016:0884-1"},{"ecosystem":"SUSE:Linux Enterprise Server for SAP Applications 12 SP1","fixed":["9.15-6.5"],"introduced":["0"],"last_affected":[],"package":"ghostscript","purl":"pkg:rpm/suse/ghostscript\u0026distro=SUSE%20Linux%20Enterprise%20Server%20for%20SAP%20Applications%2012%20SP1","source":"SUSE-SU-2016:0884-1"},{"ecosystem":"SUSE:Linux Enterprise Software Development Kit 12","fixed":["9.15-6.5"],"introduced":["0"],"last_affected":[],"package":"ghostscript","purl":"pkg:rpm/suse/ghostscript\u0026distro=SUSE%20Linux%20Enterprise%20Software%20Development%20Kit%2012","source":"SUSE-SU-2016:0884-1"},{"ecosystem":"SUSE:Linux Enterprise Software Development Kit 12 SP1","fixed":["9.15-6.5"],"introduced":["0"],"last_affected":[],"package":"ghostscript","purl":"pkg:rpm/suse/ghostscript\u0026distro=SUSE%20Linux%20Enterprise%20Software%20Development%20Kit%2012%20SP1","source":"SUSE-SU-2016:0884-1"}],"prev":{"headline":"activesupport vulnerable to Denial of Service via large XML document depth","id":"CVE-2015-3227"},"products":["n/a"],"published":"2015-08-11","related":[{"cvss_score":9.3,"headline":"Memory corruption in n/a","id":"CVE-2009-3743","kev_date_added":null,"published":"2010-08-26"},{"cvss_score":9.3,"headline":"Memory corruption in n/a","id":"CVE-2009-4897","kev_date_added":null,"published":"2010-07-22"},{"cvss_score":7.8,"headline":"Use after free in n/a","id":"CVE-2017-6196","kev_date_added":null,"published":"2017-02-24"},{"cvss_score":7.2,"headline":"Path traversal in n/a","id":"CVE-2010-2055","kev_date_added":null,"published":"2010-07-22"},{"cvss_score":5.5,"headline":"Information disclosure in n/a","id":"CVE-2013-5653","kev_date_added":null,"published":"2017-03-07"},{"cvss_score":4.3,"headline":"Denial of service in n/a","id":"CVE-2010-4054","kev_date_added":null,"published":"2010-10-22"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"SUSE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-06","vendors":["n/a"]},"summary":"Remote attackers can cause a denial of service via a crafted PostScript file due to an integer overflow in Ghostscript.","url":"https://insights.sbomify.com/CVE-2015-3228/"}