# CVE-2015-3241: OpenStack Nova instance migration process does not stop when instance is deleted

> Remote authenticated users can cause denial of service by resizing and deleting an instance, as the migration process continues consuming resources.

- **Severity:** Medium 6.8 (`AV:N/AC:L/Au:S/C:N/I:N/A:C`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 8 Sep 2015
- **Updated:** 6 Aug 2024
- **Also known as:** DEBIAN-CVE-2015-3241, GHSA-3vx7-xff6-h2vx, PYSEC-2026-861, RHSA-2015:1723, UBUNTU-CVE-2015-3241

## What is CVE-2015-3241?

CVE-2015-3241 is a medium-severity denial of service vulnerability in n/a, published on 8 Sep 2015. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

OpenStack Compute (nova) 2015.1 through 2015.1.1, 2014.2.3, and earlier does not stop the migration process when the instance is deleted, which allows remote authenticated users to cause a denial of service (disk, network, and other resource consumption) by resizing and then deleting an instance.

Weakness: CWE-399

## Which versions are affected by CVE-2015-3241?

3 open source packages ship an affected version, including nova. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `nova` | PyPI | All versions | 112.0.0.0b3 |
| `nova` | PyPI | All versions | 112.0.0.0b3 |
| `nova` | PyPI | All versions | 12.0.0.0b3 |
| `openstack-nova` | Red Hat:openstack:7::el7 | All versions | 0:2015.1.0-18.el7ost |
| `openstack-nova-api` | Red Hat:openstack:7::el7 | All versions | 0:2015.1.0-18.el7ost |
| `openstack-nova-cells` | Red Hat:openstack:7::el7 | All versions | 0:2015.1.0-18.el7ost |
| `openstack-nova-cert` | Red Hat:openstack:7::el7 | All versions | 0:2015.1.0-18.el7ost |
| `openstack-nova-common` | Red Hat:openstack:7::el7 | All versions | 0:2015.1.0-18.el7ost |
| `openstack-nova-compute` | Red Hat:openstack:7::el7 | All versions | 0:2015.1.0-18.el7ost |
| `openstack-nova-conductor` | Red Hat:openstack:7::el7 | All versions | 0:2015.1.0-18.el7ost |
| `openstack-nova-console` | Red Hat:openstack:7::el7 | All versions | 0:2015.1.0-18.el7ost |
| `openstack-nova-doc` | Red Hat:openstack:7::el7 | All versions | 0:2015.1.0-18.el7ost |
| `openstack-nova-network` | Red Hat:openstack:7::el7 | All versions | 0:2015.1.0-18.el7ost |
| `openstack-nova-novncproxy` | Red Hat:openstack:7::el7 | All versions | 0:2015.1.0-18.el7ost |
| `openstack-nova-objectstore` | Red Hat:openstack:7::el7 | All versions | 0:2015.1.0-18.el7ost |
| `openstack-nova-scheduler` | Red Hat:openstack:7::el7 | All versions | 0:2015.1.0-18.el7ost |
| `openstack-nova-serialproxy` | Red Hat:openstack:7::el7 | All versions | 0:2015.1.0-18.el7ost |
| `openstack-nova-spicehtml5proxy` | Red Hat:openstack:7::el7 | All versions | 0:2015.1.0-18.el7ost |
| `python-nova` | Red Hat:openstack:7::el7 | All versions | 0:2015.1.0-18.el7ost |

Products: Openstack Nova.

## How do I fix CVE-2015-3241?

Upgrade nova to a fixed version for your release line: 112.0.0.0b3 or 12.0.0.0b3.

## Is CVE-2015-3241 being exploited?

There is no known exploitation of CVE-2015-3241 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2017-7214](https://insights.sbomify.com/CVE-2017-7214/): OpenStack Nova logs sensitive context from notification exceptions (critical 9.8)
- [CVE-2017-17051](https://insights.sbomify.com/CVE-2017-17051/): OpenStack Nova DoS by rebuilding the same instance with a new image multiple times (high 8.6)
- [CVE-2020-17376](https://insights.sbomify.com/CVE-2020-17376/): OpenStack Nova Live migration fails to update persistent domain XML (high 8.3)
- [CVE-2017-18191](https://insights.sbomify.com/CVE-2017-18191/): OpenStack Nova Denial of service attack on the compute host (high 7.5)
- [CVE-2015-3280](https://insights.sbomify.com/CVE-2015-3280/): OpenStack Compute (nova) allows remote authenticated users to cause a denial of service (medium 6.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2015-3241 and fix it if it is affected.

What it is: CVE-2015-3241 is a medium-severity denial of service vulnerability in n/a, published on 8 Sep 2015. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2015-3241 in the wild and no public exploit code.

Affected packages and fixed versions:
- nova (PyPI): affected all versions; fixed in 112.0.0.0b3
- nova (PyPI): affected all versions; fixed in 112.0.0.0b3
- nova (PyPI): affected all versions; fixed in 12.0.0.0b3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2015-3241/ (Markdown: https://insights.sbomify.com/CVE-2015-3241/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2015-3241
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2015-3241
- OSV: https://osv.dev/vulnerability/CVE-2015-3241

---
From sbomify Insights: https://insights.sbomify.com/CVE-2015-3241/
Summaries are generated and may contain mistakes; the official description above is the record.
