{"answers":{"affected":"It affects 1 product.","exploited":"There is no known exploitation of CVE-2015-3248 in the wild and no public exploit code.","fix":"Upgrade to a fixed version.","what":"CVE-2015-3248 is a medium-severity denial of service vulnerability in n/a, published on 26 Sep 2017. It can only be exploited from the same machine or local network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2015-3248 and fix it if it is affected.\n\nWhat it is: CVE-2015-3248 is a medium-severity denial of service vulnerability in n/a, published on 26 Sep 2017. It can only be exploited from the same machine or local network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2015-3248 in the wild and no public exploit code.\n\nAffected product: n/a. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2015-3248/ (Markdown: https://insights.sbomify.com/CVE-2015-3248/index.md)","id":"CVE-2015-3248","markdown":"https://insights.sbomify.com/CVE-2015-3248/index.md","name":"CVE-2015-3248","record":{"aliases":["GHSA-pqv4-g55h-5j74","RHSA-2015:2369"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"adjacent_or_local","non_default_config":true,"product_category":"OpenHPI hardware management","requires_auth":"low_privilege","summary":"Local users can cause denial of service by filling the filesystem due to world-writable permissions in OpenHPI when quotas are not configured.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"redhat","cpe":[{"product":"openhpi","vendor":"openhpi"}],"cvss":{"score":4.7,"severity":"medium","source":"nvd","vector":"CVSS:3.0/AV:L/AC:H/PR:L/UI:N/S:U/C:N/I:N/A:H","version":"3.0"},"cwes":[{"id":"CWE-400","name":"Uncontrolled Resource Consumption"}],"description":"openhpi/Makefile.am in OpenHPI before 3.6.0 uses world-writable permissions for /var/lib/openhpi directory, which allows local users, when quotas are not properly setup, to fill the filesystem hosting /var/lib and cause a denial of service (disk consumption).","ecosystems":["Red Hat:enterprise_linux:7::computenode","Red Hat:enterprise_linux:7::server","Red Hat:enterprise_linux:7::workstation"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Denial of service in n/a","id":"CVE-2015-3248","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"denial_of_service","year":"2015"},"n_packages":12,"n_references":3,"next":{"headline":"Memory corruption in n/a","id":"CVE-2015-3249"},"packages":[{"ecosystem":"Red Hat:enterprise_linux:7::computenode","fixed":["0:3.4.0-2.el7"],"introduced":["0"],"last_affected":[],"package":"openhpi","purl":"pkg:rpm/redhat/openhpi","source":"RHSA-2015:2369"},{"ecosystem":"Red Hat:enterprise_linux:7::computenode","fixed":["0:3.4.0-2.el7"],"introduced":["0"],"last_affected":[],"package":"openhpi-debuginfo","purl":"pkg:rpm/redhat/openhpi-debuginfo","source":"RHSA-2015:2369"},{"ecosystem":"Red Hat:enterprise_linux:7::computenode","fixed":["0:3.4.0-2.el7"],"introduced":["0"],"last_affected":[],"package":"openhpi-devel","purl":"pkg:rpm/redhat/openhpi-devel","source":"RHSA-2015:2369"},{"ecosystem":"Red Hat:enterprise_linux:7::computenode","fixed":["0:3.4.0-2.el7"],"introduced":["0"],"last_affected":[],"package":"openhpi-libs","purl":"pkg:rpm/redhat/openhpi-libs","source":"RHSA-2015:2369"},{"ecosystem":"Red Hat:enterprise_linux:7::server","fixed":["0:3.4.0-2.el7"],"introduced":["0"],"last_affected":[],"package":"openhpi","purl":"pkg:rpm/redhat/openhpi","source":"RHSA-2015:2369"},{"ecosystem":"Red Hat:enterprise_linux:7::server","fixed":["0:3.4.0-2.el7"],"introduced":["0"],"last_affected":[],"package":"openhpi-debuginfo","purl":"pkg:rpm/redhat/openhpi-debuginfo","source":"RHSA-2015:2369"},{"ecosystem":"Red Hat:enterprise_linux:7::server","fixed":["0:3.4.0-2.el7"],"introduced":["0"],"last_affected":[],"package":"openhpi-devel","purl":"pkg:rpm/redhat/openhpi-devel","source":"RHSA-2015:2369"},{"ecosystem":"Red Hat:enterprise_linux:7::server","fixed":["0:3.4.0-2.el7"],"introduced":["0"],"last_affected":[],"package":"openhpi-libs","purl":"pkg:rpm/redhat/openhpi-libs","source":"RHSA-2015:2369"},{"ecosystem":"Red Hat:enterprise_linux:7::workstation","fixed":["0:3.4.0-2.el7"],"introduced":["0"],"last_affected":[],"package":"openhpi","purl":"pkg:rpm/redhat/openhpi","source":"RHSA-2015:2369"},{"ecosystem":"Red Hat:enterprise_linux:7::workstation","fixed":["0:3.4.0-2.el7"],"introduced":["0"],"last_affected":[],"package":"openhpi-debuginfo","purl":"pkg:rpm/redhat/openhpi-debuginfo","source":"RHSA-2015:2369"},{"ecosystem":"Red Hat:enterprise_linux:7::workstation","fixed":["0:3.4.0-2.el7"],"introduced":["0"],"last_affected":[],"package":"openhpi-devel","purl":"pkg:rpm/redhat/openhpi-devel","source":"RHSA-2015:2369"},{"ecosystem":"Red Hat:enterprise_linux:7::workstation","fixed":["0:3.4.0-2.el7"],"introduced":["0"],"last_affected":[],"package":"openhpi-libs","purl":"pkg:rpm/redhat/openhpi-libs","source":"RHSA-2015:2369"}],"prev":{"headline":"Race condition in n/a","id":"CVE-2015-3247"},"products":["n/a"],"published":"2017-09-26","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"Red Hat","prefix":"RHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-06","vendors":["n/a"]},"summary":"Local users can cause denial of service by filling the filesystem due to world-writable permissions in OpenHPI when quotas are not configured.","url":"https://insights.sbomify.com/CVE-2015-3248/"}