{"answers":{"affected":"2 open source packages ship an affected version, including org.apache.directory.api:api-ldap-model. It affects 1 product.","exploited":"There is no known exploitation of CVE-2015-3250 in the wild and no public exploit code.","fix":"Upgrade org.apache.directory.api:api-ldap-model to 1.0.0-M31 or later.","what":"CVE-2015-3250 is a high-severity vulnerability in n/a, published on 7 Sep 2017. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2015-3250 and fix it if it is affected.\n\nWhat it is: CVE-2015-3250 is a high-severity vulnerability in n/a, published on 7 Sep 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2015-3250 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.apache.directory.api:api-ldap-model (Maven): affected all versions; fixed in 1.0.0-M31\n- org.apache.directory.api:api-ldap-model (Maven): affected all versions; fixed in 1.0.0-M31\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2015-3250/ (Markdown: https://insights.sbomify.com/CVE-2015-3250/index.md)","id":"CVE-2015-3250","markdown":"https://insights.sbomify.com/CVE-2015-3250/index.md","name":"CVE-2015-3250","record":{"aliases":["DEBIAN-CVE-2015-3250","GHSA-cx3q-cv6w-mx4h","UBUNTU-CVE-2015-3250"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"Apache Directory LDAP API","requires_auth":"none","summary":"Attackers can conduct timing attacks to potentially disclose sensitive information via unspecified vectors in the Apache Directory LDAP API library.","user_interaction":"not_required","vuln_class":"information_disclosure"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"redhat","cpe":[{"product":"directory_ldap_api","vendor":"apache"}],"cvss":{"score":7.5,"severity":"high","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N","version":"3.0"},"cwes":[{"id":"CWE-200","name":"Exposure of Sensitive Information to an Unauthorized Actor"}],"description":"Apache Directory LDAP API before 1.0.0-M31 allows attackers to conduct timing attacks via unspecified vectors.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Exposure of Sensitive Information to an Unauthorized Actor in Apache Directory LDAP API","id":"CVE-2015-3250","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"information_disclosure","year":"2015"},"n_packages":2,"n_references":4,"next":{"headline":"Information disclosure in n/a","id":"CVE-2015-3251"},"packages":[{"ecosystem":"Maven","fixed":["1.0.0-M31"],"introduced":["0"],"last_affected":[],"package":"org.apache.directory.api:api-ldap-model","purl":null,"source":"GHSA-cx3q-cv6w-mx4h"},{"ecosystem":"Maven","fixed":["1.0.0-M31"],"introduced":["0"],"last_affected":[],"package":"org.apache.directory.api:api-ldap-model","purl":"pkg:maven/org.apache.directory.api/api-ldap-model","source":"GHSA-cx3q-cv6w-mx4h"}],"prev":{"headline":"Memory corruption in n/a","id":"CVE-2015-3249"},"products":["n/a"],"published":"2017-09-07","related":[{"cvss_score":9.8,"headline":"Credential leak in org.apache.directory.api:apache-ldap-api","id":"CVE-2018-1337","kev_date_added":null,"published":"2018-07-10"},{"cvss_score":8.8,"headline":"Apache Directory LDAP API lacks server certificate verification for LDAP hostnames","id":"CVE-2026-35563","kev_date_added":null,"published":"2026-06-01"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-06","vendors":["n/a"]},"summary":"Attackers can conduct timing attacks to potentially disclose sensitive information via unspecified vectors in the Apache Directory LDAP API library.","url":"https://insights.sbomify.com/CVE-2015-3250/"}