# CVE-2015-3250: Exposure of Sensitive Information to an Unauthorized Actor in Apache Directory LDAP API

> Attackers can conduct timing attacks to potentially disclose sensitive information via unspecified vectors in the Apache Directory LDAP API library.

- **Severity:** High 7.5 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 7 Sep 2017
- **Updated:** 6 Aug 2024
- **Also known as:** DEBIAN-CVE-2015-3250, GHSA-cx3q-cv6w-mx4h, UBUNTU-CVE-2015-3250

## What is CVE-2015-3250?

CVE-2015-3250 is a high-severity vulnerability in n/a, published on 7 Sep 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Apache Directory LDAP API before 1.0.0-M31 allows attackers to conduct timing attacks via unspecified vectors.

Weakness: CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2015-3250?

2 open source packages ship an affected version, including org.apache.directory.api:api-ldap-model. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.directory.api:api-ldap-model` | Maven | All versions | 1.0.0-M31 |
| `org.apache.directory.api:api-ldap-model` | Maven | All versions | 1.0.0-M31 |

Products: Apache Directory Ldap Api.

## How do I fix CVE-2015-3250?

Upgrade org.apache.directory.api:api-ldap-model to 1.0.0-M31 or later.

## Is CVE-2015-3250 being exploited?

There is no known exploitation of CVE-2015-3250 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2018-1337](https://insights.sbomify.com/CVE-2018-1337/): Credential leak in org.apache.directory.api:apache-ldap-api (critical 9.8)
- [CVE-2026-35563](https://insights.sbomify.com/CVE-2026-35563/): Apache Directory LDAP API lacks server certificate verification for LDAP hostnames (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2015-3250 and fix it if it is affected.

What it is: CVE-2015-3250 is a high-severity vulnerability in n/a, published on 7 Sep 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2015-3250 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.directory.api:api-ldap-model (Maven): affected all versions; fixed in 1.0.0-M31
- org.apache.directory.api:api-ldap-model (Maven): affected all versions; fixed in 1.0.0-M31

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2015-3250/ (Markdown: https://insights.sbomify.com/CVE-2015-3250/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2015-3250
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2015-3250
- OSV: https://osv.dev/vulnerability/CVE-2015-3250

---
From sbomify Insights: https://insights.sbomify.com/CVE-2015-3250/
Summaries are generated and may contain mistakes; the official description above is the record.
