# CVE-2015-3253: Improper Neutralization of Special Elements in Output Used by a Downstream Component in Apache Groovy

> Remote attackers can execute arbitrary code or cause denial of service in Apache Groovy via crafted serialized objects.

- **Severity:** Critical 9.8 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 13 Aug 2015
- **Updated:** 6 Aug 2024
- **Also known as:** DEBIAN-CVE-2015-3253, DLA-274-1, GHSA-qg25-hgjv-cg9q, MGASA-2015-0296, MGASA-2017-0333, UBUNTU-CVE-2015-3253

## What is CVE-2015-3253?

CVE-2015-3253 is a critical unsafe deserialization vulnerability in Oracle Webcenter Sites, published on 13 Aug 2015. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The MethodClosure class in runtime/MethodClosure.java in Apache Groovy 1.7.0 through 2.4.3 allows remote attackers to execute arbitrary code or cause a denial of service via a crafted serialized object.

Weakness: CWE-74 (Improper Neutralization of Special Elements in Output Used by a Downstream Component)

## Which versions are affected by CVE-2015-3253?

4 open source packages ship an affected version, including org.codehaus.groovy:groovy and org.codehaus.groovy:groovy-all. It affects 6 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.codehaus.groovy:groovy` | Maven | From 1.7.0 | 2.4.4 |
| `org.codehaus.groovy:groovy` | Maven | From 1.7.0 | 2.4.4 |
| `org.codehaus.groovy:groovy-all` | Maven | From 1.7.0 | 2.4.4 |
| `org.codehaus.groovy:groovy-all` | Maven | From 1.7.0 | 2.4.4 |

Products: Apache Groovy, Oracle Health Sciences Clinical Development Center, Oracle Retail Order Broker Cloud Service, Oracle Retail Service Backbone, Oracle Retail Store Inventory Management, Oracle Webcenter Sites.

## How do I fix CVE-2015-3253?

Upgrade org.codehaus.groovy:groovy to 2.4.4 or later.

## Is CVE-2015-3253 being exploited?

There is no known exploitation of CVE-2015-3253 in the wild and no public exploit code.

## Other vulnerabilities in Oracle Webcenter Sites

- [CVE-2016-6814](https://insights.sbomify.com/CVE-2016-6814/): Deserialization of Untrusted Data in Groovy (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2015-3253 and fix it if it is affected.

What it is: CVE-2015-3253 is a critical unsafe deserialization vulnerability in Oracle Webcenter Sites, published on 13 Aug 2015. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2015-3253 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.codehaus.groovy:groovy (Maven): affected from 1.7.0; fixed in 2.4.4
- org.codehaus.groovy:groovy (Maven): affected from 1.7.0; fixed in 2.4.4
- org.codehaus.groovy:groovy-all (Maven): affected from 1.7.0; fixed in 2.4.4
- org.codehaus.groovy:groovy-all (Maven): affected from 1.7.0; fixed in 2.4.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2015-3253/ (Markdown: https://insights.sbomify.com/CVE-2015-3253/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2015-3253
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2015-3253
- OSV: https://osv.dev/vulnerability/CVE-2015-3253

---
From sbomify Insights: https://insights.sbomify.com/CVE-2015-3253/
Summaries are generated and may contain mistakes; the official description above is the record.
