CVE-2015-3274 Moodle cross-site scripting (XSS) vulnerability
Remote attackers can inject arbitrary web script or HTML via the user_get_user_details function in Moodle, potentially compromising user sessions.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2015-3274?
CVE-2015-3274 is a medium-severity cross-site scripting vulnerability in Moodle Moodle, published on 22 Feb 2016. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Official description
Cross-site scripting (XSS) vulnerability in the user_get_user_details function in user/lib.php in Moodle through 2.6.11, 2.7.x before 2.7.9, 2.8.x before 2.8.7, and 2.9.x before 2.9.1 allows remote attackers to inject arbitrary web script or HTML by leveraging absence of an external_format_text call in a web service.
Weakness: CWE-79
Which versions are affected by CVE-2015-3274?
6 open source packages ship an affected version, including moodle/moodle. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
moodle/moodle Packagist | From 2.7.0 | 2.7.9 |
moodle/moodle Packagist | From 2.7.0 | 2.7.9 |
moodle/moodle Packagist | From 2.8.0 | 2.8.7 |
moodle/moodle Packagist | From 2.8.0 | 2.8.7 |
moodle/moodle Packagist | From 2.9.0 | 2.9.1 |
moodle/moodle Packagist | From 2.9.0 | 2.9.1 |
Products include Moodle Moodle.
How do I fix CVE-2015-3274?
Upgrade moodle/moodle to a fixed version for your release line: 2.7.9, 2.8.7 or 2.9.1.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2015-3274 being exploited?
There is no known exploitation of CVE-2015-3274 in the wild and no public exploit code.
Other vulnerabilities in Moodle Moodle
- CVE-2006-4935 File upload in n/a
- CVE-2006-4936 Moodle does not properly validate module instance id
- CVE-2004-2233 Unknown "front page vulnerability with Moodle servers" for Moodle before 1.3.2 has unknown impact and attack vectors.
- CVE-2004-2235 Cross-site scripting in n/a
- CVE-2004-2236 Other in n/a
Sources
Also known as GHSA-f7qm-q26p-6rr2.