{"answers":{"affected":"4 open source packages ship an affected version, including nodebb and nodebb-plugin-markdown. It affects 1 product.","exploited":"There is no known exploitation of CVE-2015-3296 in the wild and no public exploit code.","fix":"Upgrade nodebb to 0.70 or later.","what":"CVE-2015-3296 is a medium-severity cross-site scripting vulnerability in n/a, published on 21 Sep 2017. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2015-3296 and fix it if it is affected.\n\nWhat it is: CVE-2015-3296 is a medium-severity cross-site scripting vulnerability in n/a, published on 21 Sep 2017. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2015-3296 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- nodebb (npm): affected all versions; fixed in 0.70\n- nodebb (npm): affected all versions; fixed in 0.70\n- nodebb-plugin-markdown (npm): affected all versions; fixed in 5.1.1\n- nodebb-plugin-markdown (npm): affected all versions; fixed in 5.1.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2015-3296/ (Markdown: https://insights.sbomify.com/CVE-2015-3296/index.md)","id":"CVE-2015-3296","markdown":"https://insights.sbomify.com/CVE-2015-3296/index.md","name":"CVE-2015-3296","record":{"aliases":["GHSA-9g4f-5rpg-4948"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"NodeBB forum software","requires_auth":"none","summary":"Remote attackers can inject arbitrary web script or HTML into NodeBB forums via javascript or data URLs, potentially compromising user sessions.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"nodebb","vendor":"nodebb"}],"cvss":{"score":6.1,"severity":"medium","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N","version":"3.0"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"Multiple cross-site scripting (XSS) vulnerabilities in NodeBB before 0.7 allow remote attackers to inject arbitrary web script or HTML via vectors related to (1) javascript: or (2) data: URLs.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"NodeBB Cross-site Scripting Vulnerability in Markdown Processing","id":"CVE-2015-3296","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"xss","year":"2015"},"n_packages":4,"n_references":3,"next":{"headline":"Path traversal in n/a","id":"CVE-2015-3297"},"packages":[{"ecosystem":"npm","fixed":["0.70"],"introduced":["0"],"last_affected":[],"package":"nodebb","purl":null,"source":"GHSA-9g4f-5rpg-4948"},{"ecosystem":"npm","fixed":["0.70"],"introduced":["0"],"last_affected":[],"package":"nodebb","purl":"pkg:npm/nodebb","source":"GHSA-9g4f-5rpg-4948"},{"ecosystem":"npm","fixed":["5.1.1"],"introduced":["0"],"last_affected":[],"package":"nodebb-plugin-markdown","purl":null,"source":"GHSA-9g4f-5rpg-4948"},{"ecosystem":"npm","fixed":["5.1.1"],"introduced":["0"],"last_affected":[],"package":"nodebb-plugin-markdown","purl":"pkg:npm/nodebb-plugin-markdown","source":"GHSA-9g4f-5rpg-4948"}],"prev":{"headline":"Cross-site scripting in n/a","id":"CVE-2015-3295"},"products":["n/a"],"published":"2017-09-21","related":[{"cvss_score":10,"headline":"NodeBB vulnerable to path traversal and code execution via prototype vulnerability","id":"CVE-2023-26045","kev_date_added":null,"published":"2023-07-24"},{"cvss_score":9.9,"headline":"Account takeover in NodeBB","id":"CVE-2020-15149","kev_date_added":null,"published":"2020-08-19"},{"cvss_score":9.8,"headline":"Code injection in n/a","id":"CVE-2023-43187","kev_date_added":null,"published":"2023-09-26"},{"cvss_score":9.8,"headline":"API token verification can be bypassed","id":"CVE-2021-43786","kev_date_added":null,"published":"2021-11-29"},{"cvss_score":9.4,"headline":"Account takeover via prototype vulnerability","id":"CVE-2022-46164","kev_date_added":null,"published":"2022-12-05"},{"cvss_score":9,"headline":"Account takeover via cryptographically weak PRNG in NodeBB Forum","id":"CVE-2022-36045","kev_date_added":null,"published":"2022-08-31"},{"cvss_score":9,"headline":"XSS via prototype pollution","id":"CVE-2021-43787","kev_date_added":null,"published":"2021-11-29"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-06","vendors":["n/a"]},"summary":"Remote attackers can inject arbitrary web script or HTML into NodeBB forums via javascript or data URLs, potentially compromising user sessions.","url":"https://insights.sbomify.com/CVE-2015-3296/"}