CVE-2015-3337 Improper Limitation of a Pathname to a Restricted Directory in Elasticsearch
Remote attackers can read arbitrary files from Elasticsearch servers if a site plugin is enabled, requiring an upgrade to secure the system.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2015-3337?
CVE-2015-3337 is a medium-severity path traversal vulnerability in n/a, published on 1 May 2015. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Directory traversal vulnerability in Elasticsearch before 1.4.5 and 1.5.x before 1.5.2, when a site plugin is enabled, allows remote attackers to read arbitrary files via unspecified vectors.
Weakness: CWE-22
Which versions are affected by CVE-2015-3337?
4 open source packages ship an affected version, including org.elasticsearch:elasticsearch. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
org.elasticsearch:elasticsearch Maven | All versions | 1.4.5 |
org.elasticsearch:elasticsearch Maven | All versions | 1.4.5 |
org.elasticsearch:elasticsearch Maven | From 1.5.0 | 1.5.2 |
org.elasticsearch:elasticsearch Maven | From 1.5.0 | 1.5.2 |
Products include Elasticsearch Elasticsearch.
How do I fix CVE-2015-3337?
Upgrade org.elasticsearch:elasticsearch to a fixed version for your release line: 1.4.5 or 1.5.2.
Upgrade, and resolve every user-supplied path against an allowed base folder before opening it. More about Path traversal.
Is CVE-2015-3337 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2015-3337 exists.
Public exploit code: 1 Exploit-DB entry, 1 Nuclei template and 1 proofs of concept on GitHub.
Other vulnerabilities in n/a
Sources
Also known as DSA-3241-1, GHSA-x8q8-4hp5-463w.