# CVE-2015-3448: rest-client allows local users to obtain sensitive information by reading the log


- **Severity:** Low 2.1 (`AV:L/AC:L/Au:N/C:P/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 29 Apr 2015
- **Updated:** 6 Aug 2024
- **Also known as:** DEBIAN-CVE-2015-3448, GHSA-mx9f-w8qq-q5jf

## What is CVE-2015-3448?

CVE-2015-3448 is a low-severity vulnerability in n/a, published on 29 Apr 2015. 

### Official description

REST client for Ruby (aka rest-client) before 1.7.3 logs usernames and passwords, which allows local users to obtain sensitive information by reading the log.

Weakness: CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2015-3448?

2 open source packages ship an affected version, including rest-client. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `rest-client` | RubyGems | All versions | 1.7.3 |
| `rest-client` | RubyGems | All versions | 1.7.3 |

Products: Rest-Client Project Rest-Client.

## How do I fix CVE-2015-3448?

Upgrade rest-client to 1.7.3 or later.

## Is CVE-2015-3448 being exploited?

There is no known exploitation of CVE-2015-3448 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2019-15224](https://insights.sbomify.com/CVE-2019-15224/): rest-client Gem Contains Malicious Code (critical 9.8)
- [CVE-2015-1820](https://insights.sbomify.com/CVE-2015-1820/): rest-client Gem Vulnerable to Session Fixation (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2015-3448 and fix it if it is affected.

What it is: CVE-2015-3448 is a low-severity vulnerability in n/a, published on 29 Apr 2015. 
Exploitation: There is no known exploitation of CVE-2015-3448 in the wild and no public exploit code.

Affected packages and fixed versions:
- rest-client (RubyGems): affected all versions; fixed in 1.7.3
- rest-client (RubyGems): affected all versions; fixed in 1.7.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2015-3448/ (Markdown: https://insights.sbomify.com/CVE-2015-3448/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2015-3448
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2015-3448
- OSV: https://osv.dev/vulnerability/CVE-2015-3448

---
From sbomify Insights: https://insights.sbomify.com/CVE-2015-3448/
Summaries are generated and may contain mistakes; the official description above is the record.
