{"answers":{"affected":"3 open source packages ship an affected version, including github.com/docker/docker. It affects 1 product.","exploited":"There is no known exploitation of CVE-2015-3631 in the wild and no public exploit code.","fix":"Upgrade github.com/docker/docker to 1.6.1 or later.","what":"CVE-2015-3631 is a low-severity vulnerability in n/a, published on 18 May 2015. It can only be exploited from the same machine or local network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2015-3631 and fix it if it is affected.\n\nWhat it is: CVE-2015-3631 is a low-severity vulnerability in n/a, published on 18 May 2015. It can only be exploited from the same machine or local network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2015-3631 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- github.com/docker/docker (Go): affected all versions; fixed in 1.6.1\n- github.com/docker/docker (Go): affected all versions; fixed in 1.6.1\n- github.com/docker/docker (Go): affected all versions; fixed in 1.6.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2015-3631/ (Markdown: https://insights.sbomify.com/CVE-2015-3631/index.md)","id":"CVE-2015-3631","markdown":"https://insights.sbomify.com/CVE-2015-3631/index.md","name":"CVE-2015-3631","record":{"aliases":["DEBIAN-CVE-2015-3631","GHSA-v4h8-794j-g8mm","GO-2022-0708","UBUNTU-CVE-2015-3631"],"analysis":{"component_type":"container_or_infrastructure","fix_type":"upgrade","impacts":["privilege_escalation","security_bypass"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"Docker Engine","requires_auth":"low_privilege","summary":"Local attackers can escalate privileges and bypass security modules by using a malicious Docker image that overrides files in /proc.","user_interaction":"not_required","vuln_class":"privilege_escalation"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"docker","vendor":"docker"}],"cvss":{"score":3.6,"severity":"low","source":"nvd","vector":"AV:L/AC:L/Au:N/C:N/I:P/A:P","version":"2.0"},"cwes":[{"id":"CWE-264","name":null}],"description":"Docker Engine before 1.6.1 allows local users to set arbitrary Linux Security Modules (LSM) and docker_t policies via an image that allows volumes to override files in /proc.","ecosystems":["Go"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Arbitrary File Override in Docker Engine","id":"CVE-2015-3631","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Go","product":null,"products":[],"type":"privilege_escalation","year":"2015"},"n_packages":3,"n_references":4,"next":{"headline":"Memory corruption in n/a","id":"CVE-2015-3632"},"packages":[{"ecosystem":"Go","fixed":["1.6.1"],"introduced":["0"],"last_affected":[],"package":"github.com/docker/docker","purl":null,"source":"GHSA-v4h8-794j-g8mm"},{"ecosystem":"Go","fixed":["1.6.1"],"introduced":["0"],"last_affected":[],"package":"github.com/docker/docker","purl":"pkg:golang/github.com/docker/docker","source":"GHSA-v4h8-794j-g8mm"},{"ecosystem":"Go","fixed":["1.6.1"],"introduced":["0"],"last_affected":[],"package":"github.com/docker/docker","purl":"pkg:golang/github.com/docker/docker","source":"GO-2022-0708"}],"prev":{"headline":"Information Exposure in Docker Engine","id":"CVE-2015-3630"},"products":["n/a"],"published":"2015-05-18","related":[{"cvss_score":10,"headline":"Arbitrary Code Execution","id":"CVE-2014-9357","kev_date_added":null,"published":"2014-12-16"},{"cvss_score":8.8,"headline":"Privilege escalation in Docker","id":"CVE-2020-14298","kev_date_added":null,"published":"2020-07-13"},{"cvss_score":8.8,"headline":"Privilege escalation in Docker","id":"CVE-2020-14300","kev_date_added":null,"published":"2020-07-13"},{"cvss_score":8.8,"headline":"Deserialization in n/a","id":"CVE-2018-15514","kev_date_added":null,"published":"2018-09-01"},{"cvss_score":8.6,"headline":"Path Traversal in Docker","id":"CVE-2014-9356","kev_date_added":null,"published":"2019-12-02"},{"cvss_score":8.4,"headline":"Command injection in n/a","id":"CVE-2019-13139","kev_date_added":null,"published":"2019-08-22"},{"cvss_score":8.1,"headline":"Other in n/a","id":"CVE-2014-5282","kev_date_added":null,"published":"2018-02-06"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"Go Vulnerability Database","prefix":"GO"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-06","vendors":["n/a"]},"summary":"Local attackers can escalate privileges and bypass security modules by using a malicious Docker image that overrides files in /proc.","url":"https://insights.sbomify.com/CVE-2015-3631/"}