# CVE-2015-3631: Arbitrary File Override in Docker Engine

> Local attackers can escalate privileges and bypass security modules by using a malicious Docker image that overrides files in /proc.

- **Severity:** Low 3.6 (`AV:L/AC:L/Au:N/C:N/I:P/A:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 18 May 2015
- **Updated:** 6 Aug 2024
- **Also known as:** DEBIAN-CVE-2015-3631, GHSA-v4h8-794j-g8mm, GO-2022-0708, UBUNTU-CVE-2015-3631

## What is CVE-2015-3631?

CVE-2015-3631 is a low-severity vulnerability in n/a, published on 18 May 2015. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

Docker Engine before 1.6.1 allows local users to set arbitrary Linux Security Modules (LSM) and docker_t policies via an image that allows volumes to override files in /proc.

Weakness: CWE-264

## Which versions are affected by CVE-2015-3631?

3 open source packages ship an affected version, including github.com/docker/docker. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/docker/docker` | Go | All versions | 1.6.1 |
| `github.com/docker/docker` | Go | All versions | 1.6.1 |
| `github.com/docker/docker` | Go | All versions | 1.6.1 |

Products: Docker Docker.

## How do I fix CVE-2015-3631?

Upgrade github.com/docker/docker to 1.6.1 or later.

## Is CVE-2015-3631 being exploited?

There is no known exploitation of CVE-2015-3631 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2014-9357](https://insights.sbomify.com/CVE-2014-9357/): Arbitrary Code Execution (critical 10.0)
- [CVE-2020-14298](https://insights.sbomify.com/CVE-2020-14298/): Privilege escalation in Docker (high 8.8)
- [CVE-2020-14300](https://insights.sbomify.com/CVE-2020-14300/): Privilege escalation in Docker (high 8.8)
- [CVE-2018-15514](https://insights.sbomify.com/CVE-2018-15514/): Deserialization in n/a (high 8.8)
- [CVE-2014-9356](https://insights.sbomify.com/CVE-2014-9356/): Path Traversal in Docker (high 8.6)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2015-3631 and fix it if it is affected.

What it is: CVE-2015-3631 is a low-severity vulnerability in n/a, published on 18 May 2015. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2015-3631 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/docker/docker (Go): affected all versions; fixed in 1.6.1
- github.com/docker/docker (Go): affected all versions; fixed in 1.6.1
- github.com/docker/docker (Go): affected all versions; fixed in 1.6.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2015-3631/ (Markdown: https://insights.sbomify.com/CVE-2015-3631/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2015-3631
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2015-3631
- OSV: https://osv.dev/vulnerability/CVE-2015-3631

---
From sbomify Insights: https://insights.sbomify.com/CVE-2015-3631/
Summaries are generated and may contain mistakes; the official description above is the record.
