# CVE-2015-3880: phpBB Open Redirect

> Remote attackers can redirect users to arbitrary sites for phishing, requiring an upgrade to phpBB.

- **Severity:** Medium 6.1 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 19 Sep 2017
- **Updated:** 6 Aug 2024
- **Also known as:** GHSA-hwq7-cvp8-6hm3, UBUNTU-CVE-2015-3880

## What is CVE-2015-3880?

CVE-2015-3880 is a medium-severity vulnerability in n/a, published on 19 Sep 2017. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Open redirect vulnerability in phpBB before 3.0.14 and 3.1.x before 3.1.4 allows remote attackers to redirect users of Google Chrome to arbitrary web sites and conduct phishing attacks via unspecified vectors.

Weakness: CWE-601 (URL Redirection to Untrusted Site)

## Which versions are affected by CVE-2015-3880?

4 open source packages ship an affected version, including phpbb/phpbb. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `phpbb/phpbb` | Packagist | All versions | 3.0.14 |
| `phpbb/phpbb` | Packagist | All versions | 3.0.14 |
| `phpbb/phpbb` | Packagist | From 3.1.0 | 3.1.4 |
| `phpbb/phpbb` | Packagist | From 3.1.0 | 3.1.4 |

Products: Phpbb Phpbb.

## How do I fix CVE-2015-3880?

Upgrade phpbb/phpbb to a fixed version for your release line: 3.0.14 or 3.1.4.

## Is CVE-2015-3880 being exploited?

There is no known exploitation of CVE-2015-3880 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2008-3224](https://insights.sbomify.com/CVE-2008-3224/): Other in n/a (critical 10.0)
- [CVE-2008-1766](https://insights.sbomify.com/CVE-2008-1766/): Multiple unspecified vulnerabilities in phpBB before 3.0.1 have unknown impact and attack vectors, related to "two minor security-related bu (critical 10.0)
- [CVE-2025-70810](https://insights.sbomify.com/CVE-2025-70810/): Cross-site request forgery in n/a (high 8.8)
- [CVE-2001-1471](https://insights.sbomify.com/CVE-2001-1471/): Code injection in n/a (high 8.8)
- [CVE-2026-29199](https://insights.sbomify.com/CVE-2026-29199/): phpBB has Password Reset Link Poisoning via Host Header injection (high 8.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2015-3880 and fix it if it is affected.

What it is: CVE-2015-3880 is a medium-severity vulnerability in n/a, published on 19 Sep 2017. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2015-3880 in the wild and no public exploit code.

Affected packages and fixed versions:
- phpbb/phpbb (Packagist): affected all versions; fixed in 3.0.14
- phpbb/phpbb (Packagist): affected all versions; fixed in 3.0.14
- phpbb/phpbb (Packagist): affected from 3.1.0; fixed in 3.1.4
- phpbb/phpbb (Packagist): affected from 3.1.0; fixed in 3.1.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2015-3880/ (Markdown: https://insights.sbomify.com/CVE-2015-3880/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2015-3880
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2015-3880
- OSV: https://osv.dev/vulnerability/CVE-2015-3880

---
From sbomify Insights: https://insights.sbomify.com/CVE-2015-3880/
Summaries are generated and may contain mistakes; the official description above is the record.
