{"answers":{"affected":"It affects 1 product.","exploited":"There is no known exploitation of CVE-2015-3887 in the wild and no public exploit code.","fix":"Upgrade to a fixed version.","what":"CVE-2015-3887 is a high-severity vulnerability in n/a, published on 21 Sep 2017. It can only be exploited from the same machine or local network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2015-3887 and fix it if it is affected.\n\nWhat it is: CVE-2015-3887 is a high-severity vulnerability in n/a, published on 21 Sep 2017. It can only be exploited from the same machine or local network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2015-3887 in the wild and no public exploit code.\n\nAffected product: n/a. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2015-3887/ (Markdown: https://insights.sbomify.com/CVE-2015-3887/index.md)","id":"CVE-2015-3887","markdown":"https://insights.sbomify.com/CVE-2015-3887/index.md","name":"CVE-2015-3887","record":{"aliases":["GHSA-f7w4-66vv-c7cf","openSUSE-SU-2024:10468-1"],"analysis":{"component_type":"operating_system","fix_type":"upgrade","impacts":["privilege_escalation"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"ProxyChains-NG","requires_auth":"low_privilege","summary":"Local attackers can gain privileges by placing a malicious library in the current working directory, exploiting an untrusted search path in ProxyChains-NG.","user_interaction":"not_required","vuln_class":"privilege_escalation"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"proxychains-ng","vendor":"proxychains-ng_project"}],"cvss":{"score":7.8,"severity":"high","source":"nvd","vector":"CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H","version":"3.0"},"cwes":[{"id":"CWE-426","name":"Untrusted Search Path"}],"description":"Untrusted search path vulnerability in ProxyChains-NG before 4.9 allows local users to gain privileges via a Trojan horse libproxychains4.so library in the current working directory, which is referenced in the LD_PRELOAD path.","ecosystems":["openSUSE:Tumbleweed"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Privilege escalation in n/a","id":"CVE-2015-3887","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"privilege_escalation","year":"2015"},"n_packages":1,"n_references":6,"next":{"headline":"Other in n/a","id":"CVE-2015-3888"},"packages":[{"ecosystem":"openSUSE:Tumbleweed","fixed":["4.11-1.5"],"introduced":["0"],"last_affected":[],"package":"proxychains-ng","purl":"pkg:rpm/opensuse/proxychains-ng\u0026distro=openSUSE%20Tumbleweed","source":"openSUSE-SU-2024:10468-1"}],"prev":{"headline":"Security feature bypass in n/a","id":"CVE-2015-3886"},"products":["n/a"],"published":"2017-09-21","related":[{"cvss_score":6.9,"headline":"rofl0r/proxychains-ng \u003c= 4.17 Stack-based Buffer Overflow","id":"CVE-2025-34451","kev_date_added":null,"published":"2025-12-18"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"openSUSE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-06","vendors":["n/a"]},"summary":"Local attackers can gain privileges by placing a malicious library in the current working directory, exploiting an untrusted search path in ProxyChains-NG.","url":"https://insights.sbomify.com/CVE-2015-3887/"}