{"answers":{"affected":"2 open source packages ship an affected version, including dolibarr/dolibarr. It affects 1 product.","exploited":"There is no known exploitation of CVE-2015-3935 in the wild and no public exploit code.","fix":"Upgrade dolibarr/dolibarr to 3.5.8 or later.","what":"CVE-2015-3935 is a medium-severity cross-site scripting vulnerability in n/a, published on 10 Jun 2015. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2015-3935 and fix it if it is affected.\n\nWhat it is: CVE-2015-3935 is a medium-severity cross-site scripting vulnerability in n/a, published on 10 Jun 2015. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2015-3935 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- dolibarr/dolibarr (Packagist): affected from 3.5.0; fixed in 3.5.8\n- dolibarr/dolibarr (Packagist): affected from 3.5.0; fixed in 3.5.8\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2015-3935/ (Markdown: https://insights.sbomify.com/CVE-2015-3935/index.md)","id":"CVE-2015-3935","markdown":"https://insights.sbomify.com/CVE-2015-3935/index.md","name":"CVE-2015-3935","record":{"aliases":["GHSA-6fw8-vf2x-4wpm"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["data_read","account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"Dolibarr ERP/CRM","requires_auth":"low_privilege","summary":"Remote attackers can inject arbitrary web script via the Business Search field in Dolibarr ERP/CRM, potentially stealing user data or hijacking sessions.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"dolibarr","vendor":"dolibarr"}],"cvss":{"score":4.3,"severity":"medium","source":"nvd","vector":"AV:N/AC:M/Au:N/C:N/I:P/A:N","version":"2.0"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"Multiple cross-site scripting (XSS) vulnerabilities in Dolibarr ERP/CRM 3.5 and 3.6 allow remote attackers to inject arbitrary web script or HTML via the Business Search (search_nom) field to (1) htdocs/societe/societe.php or (2) htdocs/societe/admin/societe.php.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Dolibarr ERP and CRM contain Cross-site Scripting Vulnerability","id":"CVE-2015-3935","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"xss","year":"2015"},"n_packages":2,"n_references":5,"next":{"headline":"Denial of service in n/a","id":"CVE-2015-3938"},"packages":[{"ecosystem":"Packagist","fixed":["3.5.8"],"introduced":["3.5.0"],"last_affected":[],"package":"dolibarr/dolibarr","purl":null,"source":"GHSA-6fw8-vf2x-4wpm"},{"ecosystem":"Packagist","fixed":["3.5.8"],"introduced":["3.5.0"],"last_affected":[],"package":"dolibarr/dolibarr","purl":"pkg:composer/dolibarr/dolibarr","source":"GHSA-6fw8-vf2x-4wpm"}],"prev":{"headline":"SQL injection in n/a","id":"CVE-2015-3934"},"products":["n/a"],"published":"2015-06-10","related":[{"cvss_score":9.8,"headline":"Dolibarr Cross-site Scripting via the qty parameter in product/fournisseurs.php","id":"CVE-2019-19212","kev_date_added":null,"published":"2020-03-16"},{"cvss_score":9.8,"headline":"Dolibarr SQL injection via the integer parameters qty and value_unit","id":"CVE-2018-16809","kev_date_added":null,"published":"2019-03-07"},{"cvss_score":9.8,"headline":"Dolibarr SQL injection vulnerability","id":"CVE-2018-10094","kev_date_added":null,"published":"2018-05-22"},{"cvss_score":9.8,"headline":"Dolibarr SQL Injection vulnerability","id":"CVE-2018-9019","kev_date_added":null,"published":"2018-05-22"},{"cvss_score":9.8,"headline":"Dolibarr SQL injection vulnerability in admin/menus/edit.php","id":"CVE-2017-14238","kev_date_added":null,"published":"2017-09-11"},{"cvss_score":9.8,"headline":"Dolibarr SQL injection vulnerability in don/list.php","id":"CVE-2017-14242","kev_date_added":null,"published":"2017-09-11"},{"cvss_score":9.8,"headline":"Dolibarr ERP and CRM SQLi","id":"CVE-2017-9435","kev_date_added":null,"published":"2017-06-05"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-06","vendors":["n/a"]},"summary":"Remote attackers can inject arbitrary web script via the Business Search field in Dolibarr ERP/CRM, potentially stealing user data or hijacking sessions.","url":"https://insights.sbomify.com/CVE-2015-3935/"}