{"answers":{"affected":"2 open source packages ship an affected version, including concrete5/concrete5. It affects 1 product.","exploited":"There is no known exploitation of CVE-2015-3989 in the wild and no public exploit code.","fix":"Upgrade concrete5/concrete5 to 5.7.4 or later.","what":"CVE-2015-3989 is a medium-severity cross-site scripting vulnerability in n/a, published on 15 May 2015. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2015-3989 and fix it if it is affected.\n\nWhat it is: CVE-2015-3989 is a medium-severity cross-site scripting vulnerability in n/a, published on 15 May 2015. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2015-3989 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- concrete5/concrete5 (Packagist): affected all versions; fixed in 5.7.4\n- concrete5/concrete5 (Packagist): affected all versions; fixed in 5.7.4\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2015-3989/ (Markdown: https://insights.sbomify.com/CVE-2015-3989/index.md)","id":"CVE-2015-3989","markdown":"https://insights.sbomify.com/CVE-2015-3989/index.md","name":"CVE-2015-3989","record":{"aliases":["GHSA-jxhp-rwqv-9fjj"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution","data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"concrete5 CMS","requires_auth":"low_privilege","summary":"Remote attackers can inject arbitrary web script or HTML via private messages in concrete5, potentially compromising user sessions.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"concrete5","vendor":"concrete5"}],"cvss":{"score":4.3,"severity":"medium","source":"nvd","vector":"AV:N/AC:M/Au:N/C:N/I:P/A:N","version":"2.0"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"Multiple cross-site scripting (XSS) vulnerabilities in concrete5 before 5.7.4 allow remote attackers to inject arbitrary web script or HTML via vectors related to private messages or other unspecified vectors.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"concrete5 vulnerable to Cross-site Scripting","id":"CVE-2015-3989","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"xss","year":"2015"},"n_packages":2,"n_references":2,"next":{"headline":"Command injection in n/a","id":"CVE-2015-3990"},"packages":[{"ecosystem":"Packagist","fixed":["5.7.4"],"introduced":["0"],"last_affected":[],"package":"concrete5/concrete5","purl":null,"source":"GHSA-jxhp-rwqv-9fjj"},{"ecosystem":"Packagist","fixed":["5.7.4"],"introduced":["0"],"last_affected":[],"package":"concrete5/concrete5","purl":"pkg:composer/concrete5/concrete5","source":"GHSA-jxhp-rwqv-9fjj"}],"prev":{"headline":"Cross-site scripting in n/a","id":"CVE-2015-3988"},"products":["n/a"],"published":"2015-05-15","related":[{"cvss_score":6.1,"headline":"Cross-site scripting in n/a","id":"CVE-2017-6905","kev_date_added":null,"published":"2017-03-15"},{"cvss_score":6.1,"headline":"Cross-site scripting in n/a","id":"CVE-2017-6908","kev_date_added":null,"published":"2017-03-15"},{"cvss_score":5,"headline":"Information disclosure in n/a","id":"CVE-2014-5107","kev_date_added":null,"published":"2014-07-28"},{"cvss_score":4.3,"headline":"Cross-site scripting in n/a","id":"CVE-2015-2250","kev_date_added":null,"published":"2015-05-15"},{"cvss_score":4.3,"headline":"Cross-site scripting in n/a","id":"CVE-2014-9526","kev_date_added":null,"published":"2015-01-05"},{"cvss_score":4.3,"headline":"Cross-site scripting in n/a","id":"CVE-2014-5108","kev_date_added":null,"published":"2014-07-28"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-06","vendors":["n/a"]},"summary":"Remote attackers can inject arbitrary web script or HTML via private messages in concrete5, potentially compromising user sessions.","url":"https://insights.sbomify.com/CVE-2015-3989/"}