{"answers":{"affected":"6 open source packages ship an affected version, including rubygems-update. It affects 2 products.","exploited":"There is no known exploitation of CVE-2015-4020 in the wild and no public exploit code.","fix":"Upgrade rubygems-update to a fixed version for your release line: 2.0.17, 2.2.5 or 2.4.8.","what":"CVE-2015-4020 is a medium-severity server-side request forgery vulnerability in Oracle Solaris, published on 25 Aug 2015. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2015-4020 and fix it if it is affected.\n\nWhat it is: CVE-2015-4020 is a medium-severity server-side request forgery vulnerability in Oracle Solaris, published on 25 Aug 2015. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2015-4020 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- rubygems-update (RubyGems): affected all versions; fixed in 2.0.17\n- rubygems-update (RubyGems): affected all versions; fixed in 2.0.17\n- rubygems-update (RubyGems): affected from 2.1.0.rc.1; fixed in 2.2.5\n- rubygems-update (RubyGems): affected from 2.1.0.rc.1; fixed in 2.2.5\n- rubygems-update (RubyGems): affected from 2.3.0; fixed in 2.4.8\n- rubygems-update (RubyGems): affected from 2.3.0; fixed in 2.4.8\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2015-4020/ (Markdown: https://insights.sbomify.com/CVE-2015-4020/index.md)","id":"CVE-2015-4020","markdown":"https://insights.sbomify.com/CVE-2015-4020/index.md","name":"CVE-2015-4020","record":{"aliases":["GHSA-qv62-xfj6-32xm"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_read","code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"RubyGems package manager","requires_auth":"none","summary":"Remote attackers can redirect RubyGems requests to malicious domains via DNS hijacking, potentially leading to data theft or code execution.","user_interaction":"not_required","vuln_class":"ssrf"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"solaris","vendor":"oracle"},{"product":"rubygems","vendor":"rubygems"}],"cvss":{"score":4.3,"severity":"medium","source":"nvd","vector":"AV:N/AC:M/Au:N/C:N/I:P/A:N","version":"2.0"},"cwes":[{"id":"CWE-20","name":"Improper Input Validation"}],"description":"RubyGems 2.0.x before 2.0.17, 2.2.x before 2.2.5, and 2.4.x before 2.4.8 does not validate the hostname when fetching gems or making API requests, which allows remote attackers to redirect requests to arbitrary domains via a crafted DNS SRV record with a domain that is suffixed with the original domain name, aka a \"DNS hijack attack.\" NOTE: this vulnerability exists because to an incomplete fix for CVE-2015-3900.","ecosystems":["RubyGems"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"RubyGems Improper Input Validation vulnerability","id":"CVE-2015-4020","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"RubyGems","product":"oracle:solaris","products":["oracle:solaris"],"type":"ssrf","year":"2015"},"n_packages":6,"n_references":8,"next":{"headline":"Integer overflow in n/a","id":"CVE-2015-4021"},"packages":[{"ecosystem":"RubyGems","fixed":["2.0.17"],"introduced":["0"],"last_affected":[],"package":"rubygems-update","purl":null,"source":"GHSA-qv62-xfj6-32xm"},{"ecosystem":"RubyGems","fixed":["2.0.17"],"introduced":["0"],"last_affected":[],"package":"rubygems-update","purl":"pkg:gem/rubygems-update","source":"GHSA-qv62-xfj6-32xm"},{"ecosystem":"RubyGems","fixed":["2.2.5"],"introduced":["2.1.0.rc.1"],"last_affected":[],"package":"rubygems-update","purl":null,"source":"GHSA-qv62-xfj6-32xm"},{"ecosystem":"RubyGems","fixed":["2.2.5"],"introduced":["2.1.0.rc.1"],"last_affected":[],"package":"rubygems-update","purl":"pkg:gem/rubygems-update","source":"GHSA-qv62-xfj6-32xm"},{"ecosystem":"RubyGems","fixed":["2.4.8"],"introduced":["2.3.0"],"last_affected":[],"package":"rubygems-update","purl":null,"source":"GHSA-qv62-xfj6-32xm"},{"ecosystem":"RubyGems","fixed":["2.4.8"],"introduced":["2.3.0"],"last_affected":[],"package":"rubygems-update","purl":"pkg:gem/rubygems-update","source":"GHSA-qv62-xfj6-32xm"}],"prev":{"headline":"SQL injection in n/a","id":"CVE-2015-4018"},"products":["n/a"],"published":"2015-08-25","related":[{"cvss_score":10,"headline":"Oracle Solaris and Zettabyte File System (ZFS) Unspecified","id":"CVE-2020-14871","kev_date_added":"2021-11-03","published":"2020-10-21"},{"cvss_score":8.8,"headline":"Oracle Solaris Privilege Escalation","id":"CVE-2019-3010","kev_date_added":"2022-05-25","published":"2019-10-16"},{"cvss_score":10,"headline":"Missing authorization in Oracle Solaris","id":"CVE-2026-46978","kev_date_added":null,"published":"2026-06-16"},{"cvss_score":10,"headline":"Other in Solaris Operating System","id":"CVE-2017-3623","kev_date_added":null,"published":"2017-04-24"},{"cvss_score":10,"headline":"Memory corruption in n/a","id":"CVE-2014-0397","kev_date_added":null,"published":"2014-10-06"},{"cvss_score":10,"headline":"Other in n/a","id":"CVE-2010-3509","kev_date_added":null,"published":"2010-10-13"},{"cvss_score":10,"headline":"Auth bypass in n/a","id":"CVE-2007-0882","kev_date_added":null,"published":"2007-02-12"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-06","vendors":["n/a"]},"summary":"Remote attackers can redirect RubyGems requests to malicious domains via DNS hijacking, potentially leading to data theft or code execution.","url":"https://insights.sbomify.com/CVE-2015-4020/"}