# CVE-2015-4020: RubyGems Improper Input Validation vulnerability

> Remote attackers can redirect RubyGems requests to malicious domains via DNS hijacking, potentially leading to data theft or code execution.

- **Severity:** Medium 4.3 (`AV:N/AC:M/Au:N/C:N/I:P/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 25 Aug 2015
- **Updated:** 6 Aug 2024
- **Also known as:** GHSA-qv62-xfj6-32xm

## What is CVE-2015-4020?

CVE-2015-4020 is a medium-severity server-side request forgery vulnerability in Oracle Solaris, published on 25 Aug 2015. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

RubyGems 2.0.x before 2.0.17, 2.2.x before 2.2.5, and 2.4.x before 2.4.8 does not validate the hostname when fetching gems or making API requests, which allows remote attackers to redirect requests to arbitrary domains via a crafted DNS SRV record with a domain that is suffixed with the original domain name, aka a "DNS hijack attack." NOTE: this vulnerability exists because to an incomplete fix for CVE-2015-3900.

Weakness: CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2015-4020?

6 open source packages ship an affected version, including rubygems-update. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `rubygems-update` | RubyGems | All versions | 2.0.17 |
| `rubygems-update` | RubyGems | All versions | 2.0.17 |
| `rubygems-update` | RubyGems | From 2.1.0.rc.1 | 2.2.5 |
| `rubygems-update` | RubyGems | From 2.1.0.rc.1 | 2.2.5 |
| `rubygems-update` | RubyGems | From 2.3.0 | 2.4.8 |
| `rubygems-update` | RubyGems | From 2.3.0 | 2.4.8 |

Products: Oracle Solaris, Rubygems Rubygems.

## How do I fix CVE-2015-4020?

Upgrade rubygems-update to a fixed version for your release line: 2.0.17, 2.2.5 or 2.4.8.

## Is CVE-2015-4020 being exploited?

There is no known exploitation of CVE-2015-4020 in the wild and no public exploit code.

## Other vulnerabilities in Oracle Solaris

- [CVE-2020-14871](https://insights.sbomify.com/CVE-2020-14871/): Oracle Solaris and Zettabyte File System (ZFS) Unspecified (critical 10.0, exploited in the wild)
- [CVE-2019-3010](https://insights.sbomify.com/CVE-2019-3010/): Oracle Solaris Privilege Escalation (high 8.8, exploited in the wild)
- [CVE-2026-46978](https://insights.sbomify.com/CVE-2026-46978/): Missing authorization in Oracle Solaris (critical 10.0)
- [CVE-2017-3623](https://insights.sbomify.com/CVE-2017-3623/): Other in Solaris Operating System (critical 10.0)
- [CVE-2014-0397](https://insights.sbomify.com/CVE-2014-0397/): Memory corruption in n/a (critical 10.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2015-4020 and fix it if it is affected.

What it is: CVE-2015-4020 is a medium-severity server-side request forgery vulnerability in Oracle Solaris, published on 25 Aug 2015. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2015-4020 in the wild and no public exploit code.

Affected packages and fixed versions:
- rubygems-update (RubyGems): affected all versions; fixed in 2.0.17
- rubygems-update (RubyGems): affected all versions; fixed in 2.0.17
- rubygems-update (RubyGems): affected from 2.1.0.rc.1; fixed in 2.2.5
- rubygems-update (RubyGems): affected from 2.1.0.rc.1; fixed in 2.2.5
- rubygems-update (RubyGems): affected from 2.3.0; fixed in 2.4.8
- rubygems-update (RubyGems): affected from 2.3.0; fixed in 2.4.8

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2015-4020/ (Markdown: https://insights.sbomify.com/CVE-2015-4020/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2015-4020
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2015-4020
- OSV: https://osv.dev/vulnerability/CVE-2015-4020

---
From sbomify Insights: https://insights.sbomify.com/CVE-2015-4020/
Summaries are generated and may contain mistakes; the official description above is the record.
