CVE-2015-4050 Symfony Incorrect Access Control
Remote attackers can bypass URL signing and security rules in Symfony applications if ESI or SSI support is enabled.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2015-4050?
CVE-2015-4050 is a medium-severity vulnerability in Sensiolabs Symfony, published on 2 Jun 2015. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
FragmentListener in the HttpKernel component in Symfony 2.3.19 through 2.3.28, 2.4.9 through 2.4.10, 2.5.4 through 2.5.11, and 2.6.0 through 2.6.7, when ESI or SSI support enabled, does not check if the _controller attribute is set, which allows remote attackers to bypass URL signing and security rules by including (1) no hash or (2) an invalid hash in a request to /_fragment.
Weakness: CWE-284
Which versions are affected by CVE-2015-4050?
16 open source packages ship an affected version, including symfony/http-kernel and symfony/symfony. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
symfony/http-kernel Packagist | From 2.3.19 | 2.3.29 |
symfony/http-kernel Packagist | From 2.3.19 | 2.3.29 |
symfony/http-kernel Packagist | From 2.4.9 to 2.4.10 | None |
symfony/http-kernel Packagist | From 2.4.9 to 2.4.10 | None |
symfony/http-kernel Packagist | From 2.5.4 | 2.5.12 |
symfony/http-kernel Packagist | From 2.5.4 | 2.5.12 |
10 more packages
symfony/http-kernel Packagist | From 2.6.0 | 2.6.8 |
symfony/http-kernel Packagist | From 2.6.0 | 2.6.8 |
symfony/symfony Packagist | From 2.3.19 | 2.3.29 |
symfony/symfony Packagist | From 2.3.19 | 2.3.29 |
symfony/symfony Packagist | From 2.4.9 to 2.4.10 | None |
symfony/symfony Packagist | From 2.4.9 to 2.4.10 | None |
symfony/symfony Packagist | From 2.5.4 | 2.5.12 |
symfony/symfony Packagist | From 2.5.4 | 2.5.12 |
symfony/symfony Packagist | From 2.6.0 | 2.6.8 |
symfony/symfony Packagist | From 2.6.0 | 2.6.8 |
Products include Sensiolabs Symfony.
How do I fix CVE-2015-4050?
Upgrade symfony/http-kernel to a fixed version for your release line: 2.3.29, 2.5.12 or 2.6.8.
Is CVE-2015-4050 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2015-4050 exists.
Public exploit code: 1 Nuclei template.
Other vulnerabilities in Sensiolabs Symfony
Sources
Also known as DEBIAN-CVE-2015-4050, DSA-3276-1, GHSA-qmqw-mpqp-mr54.