# CVE-2015-4050: Symfony Incorrect Access Control

> Remote attackers can bypass URL signing and security rules in Symfony applications if ESI or SSI support is enabled.

- **Severity:** Medium 4.3 (`AV:N/AC:M/Au:N/C:N/I:P/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 2 Jun 2015
- **Updated:** 6 Aug 2024
- **Also known as:** DEBIAN-CVE-2015-4050, DSA-3276-1, GHSA-qmqw-mpqp-mr54

## What is CVE-2015-4050?

CVE-2015-4050 is a medium-severity vulnerability in Sensiolabs Symfony, published on 2 Jun 2015. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

FragmentListener in the HttpKernel component in Symfony 2.3.19 through 2.3.28, 2.4.9 through 2.4.10, 2.5.4 through 2.5.11, and 2.6.0 through 2.6.7, when ESI or SSI support enabled, does not check if the _controller attribute is set, which allows remote attackers to bypass URL signing and security rules by including (1) no hash or (2) an invalid hash in a request to /_fragment.

Weakness: CWE-284 (Improper Access Control)

## Which versions are affected by CVE-2015-4050?

16 open source packages ship an affected version, including symfony/http-kernel and symfony/symfony. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `symfony/http-kernel` | Packagist | From 2.3.19 | 2.3.29 |
| `symfony/http-kernel` | Packagist | From 2.3.19 | 2.3.29 |
| `symfony/http-kernel` | Packagist | From 2.4.9 to 2.4.10 | None |
| `symfony/http-kernel` | Packagist | From 2.4.9 to 2.4.10 | None |
| `symfony/http-kernel` | Packagist | From 2.5.4 | 2.5.12 |
| `symfony/http-kernel` | Packagist | From 2.5.4 | 2.5.12 |
| `symfony/http-kernel` | Packagist | From 2.6.0 | 2.6.8 |
| `symfony/http-kernel` | Packagist | From 2.6.0 | 2.6.8 |
| `symfony/symfony` | Packagist | From 2.3.19 | 2.3.29 |
| `symfony/symfony` | Packagist | From 2.3.19 | 2.3.29 |
| `symfony/symfony` | Packagist | From 2.4.9 to 2.4.10 | None |
| `symfony/symfony` | Packagist | From 2.4.9 to 2.4.10 | None |
| `symfony/symfony` | Packagist | From 2.5.4 | 2.5.12 |
| `symfony/symfony` | Packagist | From 2.5.4 | 2.5.12 |
| `symfony/symfony` | Packagist | From 2.6.0 | 2.6.8 |
| `symfony/symfony` | Packagist | From 2.6.0 | 2.6.8 |

Products: Sensiolabs Symfony.

## How do I fix CVE-2015-4050?

Upgrade symfony/http-kernel to a fixed version for your release line: 2.3.29, 2.5.12 or 2.6.8.

## Is CVE-2015-4050 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2015-4050 exists.

Public exploit code:

- Symfony - Authentication Bypass (nuclei): http/cves/2015/CVE-2015-4050.yaml

## Other vulnerabilities in Sensiolabs Symfony

- [CVE-2019-11325](https://insights.sbomify.com/CVE-2019-11325/): Improper Input Validation in Symfony (critical 9.8)
- [CVE-2017-11365](https://insights.sbomify.com/CVE-2017-11365/): Symfony Incorrect Access Control (critical 9.8)
- [CVE-2019-10913](https://insights.sbomify.com/CVE-2019-10913/): Invalid HTTP method overrides allow possible XSS or other attacks in Symfony (critical 9.8)
- [CVE-2018-11407](https://insights.sbomify.com/CVE-2018-11407/): Symfony Authentication Bypass (critical 9.8)
- [CVE-2016-2403](https://insights.sbomify.com/CVE-2016-2403/): Symfony Authentication Bypass (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2015-4050 and fix it if it is affected.

What it is: CVE-2015-4050 is a medium-severity vulnerability in Sensiolabs Symfony, published on 2 Jun 2015. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2015-4050 exists.

Affected packages and fixed versions:
- symfony/http-kernel (Packagist): affected from 2.3.19; fixed in 2.3.29
- symfony/http-kernel (Packagist): affected from 2.3.19; fixed in 2.3.29
- symfony/http-kernel (Packagist): affected from 2.4.9 up to 2.4.10; no fix listed
- symfony/http-kernel (Packagist): affected from 2.4.9 up to 2.4.10; no fix listed
- symfony/http-kernel (Packagist): affected from 2.5.4; fixed in 2.5.12
- symfony/http-kernel (Packagist): affected from 2.5.4; fixed in 2.5.12
- symfony/http-kernel (Packagist): affected from 2.6.0; fixed in 2.6.8
- symfony/http-kernel (Packagist): affected from 2.6.0; fixed in 2.6.8
- symfony/symfony (Packagist): affected from 2.3.19; fixed in 2.3.29
- symfony/symfony (Packagist): affected from 2.3.19; fixed in 2.3.29
- symfony/symfony (Packagist): affected from 2.4.9 up to 2.4.10; no fix listed
- symfony/symfony (Packagist): affected from 2.4.9 up to 2.4.10; no fix listed

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2015-4050/ (Markdown: https://insights.sbomify.com/CVE-2015-4050/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2015-4050
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2015-4050
- OSV: https://osv.dev/vulnerability/CVE-2015-4050

---
From sbomify Insights: https://insights.sbomify.com/CVE-2015-4050/
Summaries are generated and may contain mistakes; the official description above is the record.
