# CVE-2015-4053: ceph-deploy uses world-readable permissions on client.admin key

> Local attackers can read sensitive Ceph admin keyring files due to insecure world-readable permissions in ceph-deploy.

- **Severity:** Low 2.1 (`AV:L/AC:L/Au:N/C:P/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 8 Jun 2015
- **Updated:** 6 Aug 2024
- **Also known as:** GHSA-79jf-ccm8-43w7, PYSEC-2015-3, openSUSE-SU-2024:10213-1

## What is CVE-2015-4053?

CVE-2015-4053 is a low-severity vulnerability in n/a, published on 8 Jun 2015. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

The admin command in ceph-deploy before 1.5.25 uses world-readable permissions for /etc/ceph/ceph.client.admin.keyring, which allows local users to obtain sensitive information by reading the file.

Weakness: CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2015-4053?

3 open source packages ship an affected version, including ceph-deploy. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `ceph-deploy` | PyPI | All versions | 1.5.23 |
| `ceph-deploy` | PyPI | All versions | 1.5.25 |
| `ceph-deploy` | PyPI | All versions | 1.5.25 |
| `ceph-deploy` | openSUSE:Tumbleweed | All versions | 1.5.34+git.1470736983.963ba71-1.1 |

Products: Ceph Ceph-Deploy.

## How do I fix CVE-2015-4053?

Upgrade ceph-deploy to a fixed version for your release line: 1.5.23 or 1.5.25.

## Is CVE-2015-4053 being exploited?

There is no known exploitation of CVE-2015-4053 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2015-3010](https://insights.sbomify.com/CVE-2015-3010/): ceph-deploy allows local users to obtain sensitive information by reading the file (low 2.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2015-4053 and fix it if it is affected.

What it is: CVE-2015-4053 is a low-severity vulnerability in n/a, published on 8 Jun 2015. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2015-4053 in the wild and no public exploit code.

Affected packages and fixed versions:
- ceph-deploy (PyPI): affected all versions; fixed in 1.5.23
- ceph-deploy (PyPI): affected all versions; fixed in 1.5.25
- ceph-deploy (PyPI): affected all versions; fixed in 1.5.25

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2015-4053/ (Markdown: https://insights.sbomify.com/CVE-2015-4053/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2015-4053
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2015-4053
- OSV: https://osv.dev/vulnerability/CVE-2015-4053

---
From sbomify Insights: https://insights.sbomify.com/CVE-2015-4053/
Summaries are generated and may contain mistakes; the official description above is the record.
