{"answers":{"affected":"3 open source packages ship an affected version, including attic. It affects 1 product.","exploited":"There is no known exploitation of CVE-2015-4082 in the wild and no public exploit code.","fix":"Upgrade attic to 0.15 or later.","what":"CVE-2015-4082 is a medium-severity vulnerability in n/a, published on 18 Aug 2017. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2015-4082 and fix it if it is affected.\n\nWhat it is: CVE-2015-4082 is a medium-severity vulnerability in n/a, published on 18 Aug 2017. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2015-4082 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- attic (PyPI): affected all versions; fixed in 0.15\n- attic (PyPI): affected all versions; fixed in 0.15\n- attic (PyPI): affected all versions; fixed in 0.15\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2015-4082/ (Markdown: https://insights.sbomify.com/CVE-2015-4082/index.md)","id":"CVE-2015-4082","markdown":"https://insights.sbomify.com/CVE-2015-4082/index.md","name":"CVE-2015-4082","record":{"aliases":["GHSA-5x6q-ffwj-8vcf","PYSEC-2017-6","UBUNTU-CVE-2015-4082"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_read","security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"Python backup library","requires_auth":"low_privilege","summary":"Attackers can bypass encryption checks in Attic backups by modifying the manifest, potentially exposing sensitive data.","user_interaction":"not_required","vuln_class":"security_feature_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"attic","vendor":"attic_project"}],"cvss":{"score":6.5,"severity":"medium","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N","version":"3.0"},"cwes":[{"id":"CWE-264","name":null}],"description":"attic before 0.15 does not confirm unencrypted backups with the user, which allows remote attackers with read and write privileges for the encrypted repository to obtain potentially sensitive information by changing the manifest type byte of the repository to \"unencrypted / without key file\".","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"attic has improper verification of unencrypted backups","id":"CVE-2015-4082","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"security_feature_bypass","year":"2015"},"n_packages":3,"n_references":4,"next":{"headline":"Cross-site scripting in n/a","id":"CVE-2015-4084"},"packages":[{"ecosystem":"PyPI","fixed":["0.15"],"introduced":["0"],"last_affected":[],"package":"attic","purl":null,"source":"GHSA-5x6q-ffwj-8vcf"},{"ecosystem":"PyPI","fixed":["0.15"],"introduced":["0"],"last_affected":[],"package":"attic","purl":"pkg:pypi/attic","source":"GHSA-5x6q-ffwj-8vcf"},{"ecosystem":"PyPI","fixed":["0.15"],"introduced":["0"],"last_affected":[],"package":"attic","purl":"pkg:pypi/attic","source":"PYSEC-2017-6"}],"prev":{"headline":"Hardcoded credentials in n/a","id":"CVE-2015-4080"},"products":["n/a"],"published":"2017-08-18","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-06","vendors":["n/a"]},"summary":"Attackers can bypass encryption checks in Attic backups by modifying the manifest, potentially exposing sensitive data.","url":"https://insights.sbomify.com/CVE-2015-4082/"}