{"answers":{"affected":"It affects 7 products.","exploited":"There is no known exploitation of CVE-2015-4142 in the wild and no public exploit code.","fix":"Apply the vendor's patch.","what":"CVE-2015-4142 is a medium-severity vulnerability in Opensuse Opensuse, published on 15 Jun 2015. It can only be exploited from the same machine or local network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2015-4142 and fix it if it is affected.\n\nWhat it is: CVE-2015-4142 is a medium-severity vulnerability in Opensuse Opensuse, published on 15 Jun 2015. It can only be exploited from the same machine or local network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2015-4142 in the wild and no public exploit code.\n\nAffected product: Opensuse Opensuse. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2015-4142/ (Markdown: https://insights.sbomify.com/CVE-2015-4142/index.md)","id":"CVE-2015-4142","markdown":"https://insights.sbomify.com/CVE-2015-4142/index.md","name":"CVE-2015-4142","record":{"aliases":["DEBIAN-CVE-2015-4142","DLA-260-1","GHSA-r4j8-fwxp-qfmx","RHSA-2015:1439","UBUNTU-CVE-2015-4142"],"analysis":{"component_type":"network_device","fix_type":"patch","impacts":["denial_of_service"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"Wi-Fi access point software","requires_auth":"none","summary":"Remote attackers can crash Wi-Fi access points or clients via crafted WMM Action frames due to an integer underflow in hostapd and wpa_supplicant.","user_interaction":"not_required","vuln_class":"integer_overflow"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"opensuse","vendor":"opensuse"},{"product":"enterprise_linux_desktop","vendor":"redhat"},{"product":"enterprise_linux_hpc_node","vendor":"redhat"},{"product":"enterprise_linux_server","vendor":"redhat"},{"product":"enterprise_linux_workstation","vendor":"redhat"},{"product":"hostapd","vendor":"w1.fi"},{"product":"wpa_supplicant","vendor":"w1.fi"}],"cvss":{"score":4.3,"severity":"medium","source":"nvd","vector":"AV:N/AC:M/Au:N/C:N/I:N/A:P","version":"2.0"},"cwes":[{"id":"CWE-119","name":"Improper Restriction of Operations within the Bounds of a Memory Buffer"}],"description":"Integer underflow in the WMM Action frame parser in hostapd 0.5.5 through 2.4 and wpa_supplicant 0.7.0 through 2.4, when used for AP mode MLME/SME functionality, allows remote attackers to cause a denial of service (crash) via a crafted frame, which triggers an out-of-bounds read.","ecosystems":["Red Hat:enterprise_linux:6::client","Red Hat:enterprise_linux:6::computenode","Red Hat:enterprise_linux:6::server","Red Hat:enterprise_linux:6::workstation"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Integer overflow in n/a","id":"CVE-2015-4142","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":"opensuse:opensuse","products":["opensuse:opensuse","redhat:enterprise_linux_desktop","redhat:enterprise_linux_hpc_node","redhat:enterprise_linux_server","redhat:enterprise_linux_workstation"],"type":"integer_overflow","year":"2015"},"n_packages":8,"n_references":15,"next":{"headline":"Denial of service in n/a","id":"CVE-2015-4143"},"packages":[{"ecosystem":"Red Hat:enterprise_linux:6::client","fixed":["1:0.7.3-6.el6"],"introduced":["0"],"last_affected":[],"package":"wpa_supplicant","purl":"pkg:rpm/redhat/wpa_supplicant","source":"RHSA-2015:1439"},{"ecosystem":"Red Hat:enterprise_linux:6::client","fixed":["1:0.7.3-6.el6"],"introduced":["0"],"last_affected":[],"package":"wpa_supplicant-debuginfo","purl":"pkg:rpm/redhat/wpa_supplicant-debuginfo","source":"RHSA-2015:1439"},{"ecosystem":"Red Hat:enterprise_linux:6::computenode","fixed":["1:0.7.3-6.el6"],"introduced":["0"],"last_affected":[],"package":"wpa_supplicant","purl":"pkg:rpm/redhat/wpa_supplicant","source":"RHSA-2015:1439"},{"ecosystem":"Red Hat:enterprise_linux:6::computenode","fixed":["1:0.7.3-6.el6"],"introduced":["0"],"last_affected":[],"package":"wpa_supplicant-debuginfo","purl":"pkg:rpm/redhat/wpa_supplicant-debuginfo","source":"RHSA-2015:1439"},{"ecosystem":"Red Hat:enterprise_linux:6::server","fixed":["1:0.7.3-6.el6"],"introduced":["0"],"last_affected":[],"package":"wpa_supplicant","purl":"pkg:rpm/redhat/wpa_supplicant","source":"RHSA-2015:1439"},{"ecosystem":"Red Hat:enterprise_linux:6::server","fixed":["1:0.7.3-6.el6"],"introduced":["0"],"last_affected":[],"package":"wpa_supplicant-debuginfo","purl":"pkg:rpm/redhat/wpa_supplicant-debuginfo","source":"RHSA-2015:1439"},{"ecosystem":"Red Hat:enterprise_linux:6::workstation","fixed":["1:0.7.3-6.el6"],"introduced":["0"],"last_affected":[],"package":"wpa_supplicant","purl":"pkg:rpm/redhat/wpa_supplicant","source":"RHSA-2015:1439"},{"ecosystem":"Red Hat:enterprise_linux:6::workstation","fixed":["1:0.7.3-6.el6"],"introduced":["0"],"last_affected":[],"package":"wpa_supplicant-debuginfo","purl":"pkg:rpm/redhat/wpa_supplicant-debuginfo","source":"RHSA-2015:1439"}],"prev":{"headline":"Memory corruption in n/a","id":"CVE-2015-4141"},"products":["n/a"],"published":"2015-06-15","related":[{"cvss_score":10,"headline":"Memory corruption in n/a","id":"CVE-2015-5957","kev_date_added":null,"published":"2015-09-28"},{"cvss_score":10,"headline":"Memory corruption in n/a","id":"CVE-2015-0491","kev_date_added":null,"published":"2015-04-16"},{"cvss_score":10,"headline":"Integer overflow in n/a","id":"CVE-2008-2388","kev_date_added":null,"published":"2008-06-06"},{"cvss_score":9.8,"headline":"Integer overflow in n/a","id":"CVE-2010-1866","kev_date_added":null,"published":"2010-05-07"},{"cvss_score":9.3,"headline":"Other in n/a","id":"CVE-2015-0492","kev_date_added":null,"published":"2015-04-16"},{"cvss_score":8.8,"headline":"Memory corruption in n/a","id":"CVE-2014-0158","kev_date_added":null,"published":"2018-04-10"},{"cvss_score":8.8,"headline":"Null dereference in n/a","id":"CVE-2016-4343","kev_date_added":null,"published":"2016-05-22"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"Red Hat","prefix":"RHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-06","vendors":["n/a"]},"summary":"Remote attackers can crash Wi-Fi access points or clients via crafted WMM Action frames due to an integer underflow in hostapd and wpa_supplicant.","url":"https://insights.sbomify.com/CVE-2015-4142/"}