{"answers":{"affected":"2 open source packages ship an affected version, including org.elasticsearch:elasticsearch. It affects 1 product.","exploited":"There is no known exploitation of CVE-2015-4165 in the wild and no public exploit code.","fix":"Upgrade org.elasticsearch:elasticsearch to 1.6.0 or later.","what":"CVE-2015-4165 is a high-severity code injection vulnerability in n/a, published on 9 Aug 2017. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2015-4165 and fix it if it is affected.\n\nWhat it is: CVE-2015-4165 is a high-severity code injection vulnerability in n/a, published on 9 Aug 2017. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2015-4165 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.elasticsearch:elasticsearch (Maven): affected all versions; fixed in 1.6.0\n- org.elasticsearch:elasticsearch (Maven): affected all versions; fixed in 1.6.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2015-4165/ (Markdown: https://insights.sbomify.com/CVE-2015-4165/index.md)","id":"CVE-2015-4165","markdown":"https://insights.sbomify.com/CVE-2015-4165/index.md","name":"CVE-2015-4165","record":{"aliases":["GHSA-fh5x-4j57-6q5x"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":true,"product_category":"Elasticsearch search engine","requires_auth":"low_privilege","summary":"Authenticated attackers can execute arbitrary code via snapshot API if specific file system permissions and external applications are present.","user_interaction":"not_required","vuln_class":"code_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"elasticsearch","vendor":"elasticsearch"}],"cvss":{"score":7.5,"severity":"high","source":"nvd","vector":"CVSS:3.0/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H","version":"3.0"},"cwes":[{"id":"CWE-264","name":null}],"description":"The snapshot API in Elasticsearch before 1.6.0 when another application exists on the system that can read Lucene files and execute code from them, is accessible by the attacker, and the Java VM on which Elasticsearch is running can write to a location that the other application can read and execute from, allows remote authenticated users to write to and create arbitrary snapshot metadata files, and potentially execute arbitrary code.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Improper Access Control in Elasticsearch","id":"CVE-2015-4165","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"code_injection","year":"2015"},"n_packages":2,"n_references":6,"next":{"headline":"Other in n/a","id":"CVE-2015-4166"},"packages":[{"ecosystem":"Maven","fixed":["1.6.0"],"introduced":["0"],"last_affected":[],"package":"org.elasticsearch:elasticsearch","purl":null,"source":"GHSA-fh5x-4j57-6q5x"},{"ecosystem":"Maven","fixed":["1.6.0"],"introduced":["0"],"last_affected":[],"package":"org.elasticsearch:elasticsearch","purl":"pkg:maven/org.elasticsearch/elasticsearch","source":"GHSA-fh5x-4j57-6q5x"}],"prev":{"headline":"Denial of service in n/a","id":"CVE-2015-4164"},"products":["n/a"],"published":"2017-08-09","related":[{"cvss_score":5,"headline":"Improper Limitation of a Pathname to a Restricted Directory in Elasticsearch","id":"CVE-2015-5531","kev_date_added":null,"published":"2015-08-17"},{"cvss_score":4.3,"headline":"Improper Limitation of a Pathname to a Restricted Directory in Elasticsearch","id":"CVE-2015-3337","kev_date_added":null,"published":"2015-05-01"},{"cvss_score":4.3,"headline":"Cross-site scripting in Elasticsearch","id":"CVE-2014-6439","kev_date_added":null,"published":"2014-10-10"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-06","vendors":["n/a"]},"summary":"Authenticated attackers can execute arbitrary code via snapshot API if specific file system permissions and external applications are present.","url":"https://insights.sbomify.com/CVE-2015-4165/"}