{"answers":{"affected":"It affects 4 products.","exploited":"There is no known exploitation of CVE-2015-4171 in the wild and no public exploit code.","fix":"Upgrade to a fixed version.","what":"CVE-2015-4171 is a low-severity vulnerability in Canonical Ubuntu Linux, published on 10 Jun 2015. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2015-4171 and fix it if it is affected.\n\nWhat it is: CVE-2015-4171 is a low-severity vulnerability in Canonical Ubuntu Linux, published on 10 Jun 2015. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2015-4171 in the wild and no public exploit code.\n\nAffected product: Canonical Ubuntu Linux. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2015-4171/ (Markdown: https://insights.sbomify.com/CVE-2015-4171/index.md)","id":"CVE-2015-4171","markdown":"https://insights.sbomify.com/CVE-2015-4171/index.md","name":"CVE-2015-4171","record":{"aliases":["DEBIAN-CVE-2015-4171","DLA-244-1","DSA-3282-1","GHSA-mg6m-fcfp-8xqm","SUSE-SU-2015:1196-1","SUSE-SU-2015:1791-1","UBUNTU-CVE-2015-4171","USN-2628-1"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["data_read"],"network_reachable":"yes","non_default_config":true,"product_category":"strongSwan VPN","requires_auth":"none","summary":"Remote attackers can obtain credentials by exploiting a flaw in strongSwan's IKEv2 authentication process when using EAP or pre-shared keys.","user_interaction":"not_required","vuln_class":"information_disclosure"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"ubuntu_linux","vendor":"canonical"},{"product":"debian_linux","vendor":"debian"},{"product":"strongswan","vendor":"strongswan"},{"product":"strongswan_vpn_client","vendor":"strongswan"}],"cvss":{"score":2.6,"severity":"low","source":"nvd","vector":"AV:N/AC:H/Au:N/C:P/I:N/A:N","version":"2.0"},"cwes":[{"id":"CWE-200","name":"Exposure of Sensitive Information to an Unauthorized Actor"}],"description":"strongSwan 4.3.0 through 5.x before 5.3.2 and strongSwan VPN Client before 1.4.6, when using EAP or pre-shared keys for authenticating an IKEv2 connection, does not enforce server authentication restrictions until the entire authentication process is complete, which allows remote servers to obtain credentials by using a valid certificate and then reading the responses.","ecosystems":["SUSE:Linux Enterprise Desktop 12","SUSE:Linux Enterprise Server 11 SP4","SUSE:Linux Enterprise Server 12","SUSE:Linux Enterprise Server for SAP Applications 11 SP4","SUSE:Linux Enterprise Server for SAP Applications 12"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Information disclosure in n/a","id":"CVE-2015-4171","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":"canonical:ubuntu_linux","products":["canonical:ubuntu_linux","debian:debian_linux"],"type":"information_disclosure","year":"2015"},"n_packages":5,"n_references":12,"next":{"headline":"Privilege escalation in n/a","id":"CVE-2015-4173"},"packages":[{"ecosystem":"SUSE:Linux Enterprise Desktop 12","fixed":["5.1.3-18.1"],"introduced":["0"],"last_affected":[],"package":"strongswan","purl":"pkg:rpm/suse/strongswan\u0026distro=SUSE%20Linux%20Enterprise%20Desktop%2012","source":"SUSE-SU-2015:1196-1"},{"ecosystem":"SUSE:Linux Enterprise Server 11 SP4","fixed":["4.4.0-6.29.2"],"introduced":["0"],"last_affected":[],"package":"strongswan","purl":"pkg:rpm/suse/strongswan\u0026distro=SUSE%20Linux%20Enterprise%20Server%2011%20SP4","source":"SUSE-SU-2015:1791-1"},{"ecosystem":"SUSE:Linux Enterprise Server 12","fixed":["5.1.3-18.1"],"introduced":["0"],"last_affected":[],"package":"strongswan","purl":"pkg:rpm/suse/strongswan\u0026distro=SUSE%20Linux%20Enterprise%20Server%2012","source":"SUSE-SU-2015:1196-1"},{"ecosystem":"SUSE:Linux Enterprise Server for SAP Applications 11 SP4","fixed":["4.4.0-6.29.2"],"introduced":["0"],"last_affected":[],"package":"strongswan","purl":"pkg:rpm/suse/strongswan\u0026distro=SUSE%20Linux%20Enterprise%20Server%20for%20SAP%20Applications%2011%20SP4","source":"SUSE-SU-2015:1791-1"},{"ecosystem":"SUSE:Linux Enterprise Server for SAP Applications 12","fixed":["5.1.3-18.1"],"introduced":["0"],"last_affected":[],"package":"strongswan","purl":"pkg:rpm/suse/strongswan\u0026distro=SUSE%20Linux%20Enterprise%20Server%20for%20SAP%20Applications%2012","source":"SUSE-SU-2015:1196-1"}],"prev":{"headline":"Race condition in n/a","id":"CVE-2015-4170"},"products":["n/a"],"published":"2015-06-10","related":[{"cvss_score":9.8,"headline":"SaltStack Salt Authentication Bypass","id":"CVE-2020-11651","kev_date_added":"2021-11-03","published":"2020-04-30"},{"cvss_score":9.8,"headline":"OpenSMTPD Remote Code Execution","id":"CVE-2020-7247","kev_date_added":"2022-03-25","published":"2020-01-29"},{"cvss_score":9.8,"headline":"Exim Out-of-bounds Write","id":"CVE-2019-16928","kev_date_added":"2022-03-03","published":"2019-09-27"},{"cvss_score":9.8,"headline":"Exim Buffer Overflow","id":"CVE-2018-6789","kev_date_added":"2021-11-03","published":"2018-02-08"},{"cvss_score":9.8,"headline":"Oracle Java SE and Java SE Embedded Remote Code Execution","id":"CVE-2015-2590","kev_date_added":"2022-03-03","published":"2015-07-16"},{"cvss_score":9.8,"headline":"Oracle JRE Remote Code Execution","id":"CVE-2013-0422","kev_date_added":"2022-05-25","published":"2013-01-10"},{"cvss_score":9.8,"headline":"Oracle Java SE Runtime Environment (JRE) Arbitrary Code Execution","id":"CVE-2011-3544","kev_date_added":"2022-03-03","published":"2011-10-19"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"SUSE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-06","vendors":["n/a"]},"summary":"Remote attackers can obtain credentials by exploiting a flaw in strongSwan's IKEv2 authentication process when using EAP or pre-shared keys.","url":"https://insights.sbomify.com/CVE-2015-4171/"}