{"answers":{"affected":"2 open source packages ship an affected version, including bson. It affects 2 products.","exploited":"There is no known exploitation of CVE-2015-4411 in the wild and no public exploit code.","fix":"Upgrade bson to 3.0.4 or later.","what":"CVE-2015-4411 is a high-severity denial of service vulnerability in Fedoraproject Fedora, published on 20 Feb 2020. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2015-4411 and fix it if it is affected.\n\nWhat it is: CVE-2015-4411 is a high-severity denial of service vulnerability in Fedoraproject Fedora, published on 20 Feb 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2015-4411 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- bson (RubyGems): affected all versions; fixed in 3.0.4\n- bson (RubyGems): affected all versions; fixed in 3.0.4\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2015-4411/ (Markdown: https://insights.sbomify.com/CVE-2015-4411/index.md)","id":"CVE-2015-4411","markdown":"https://insights.sbomify.com/CVE-2015-4411/index.md","name":"CVE-2015-4411","record":{"aliases":["GHSA-qh4w-7pw3-p4rp"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Ruby BSON library","requires_auth":"none","summary":"Remote attackers can cause denial of service via resource consumption using crafted strings in the BSON ObjectId validation method.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"fedora","vendor":"fedoraproject"},{"product":"bson","vendor":"mongodb"}],"cvss":{"score":7.5,"severity":"high","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","version":"3.1"},"cwes":[{"id":"CWE-400","name":"Uncontrolled Resource Consumption"}],"description":"The Moped::BSON::ObjecId.legal? method in mongodb/bson-ruby before 3.0.4 as used in rubygem-moped allows remote attackers to cause a denial of service (worker resource consumption) via a crafted string. NOTE: This issue is due to an incomplete fix to CVE-2015-4410.","ecosystems":["RubyGems"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"BSON rubygem contains potential denial of service","id":"CVE-2015-4411","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"RubyGems","product":"fedoraproject:fedora","products":["fedoraproject:fedora"],"type":"denial_of_service","year":"2015"},"n_packages":2,"n_references":14,"next":{"headline":"bson is vulnerable to denial of service due to incorrect regex validation","id":"CVE-2015-4412"},"packages":[{"ecosystem":"RubyGems","fixed":["3.0.4"],"introduced":["0"],"last_affected":[],"package":"bson","purl":null,"source":"GHSA-qh4w-7pw3-p4rp"},{"ecosystem":"RubyGems","fixed":["3.0.4"],"introduced":["0"],"last_affected":[],"package":"bson","purl":"pkg:gem/bson","source":"GHSA-qh4w-7pw3-p4rp"}],"prev":{"headline":"Moped Rubygem Data Injection Vulnerability","id":"CVE-2015-4410"},"products":["n/a"],"published":"2020-02-20","related":[{"cvss_score":9.8,"headline":"PHP-CGI OS Command Injection","id":"CVE-2024-4577","kev_date_added":"2024-06-12","published":"2024-06-09"},{"cvss_score":9.8,"headline":"Grafana Authentication Bypass","id":"CVE-2021-39226","kev_date_added":"2022-08-25","published":"2021-10-05"},{"cvss_score":9.8,"headline":"VMware ESXi and Horizon DaaS OpenSLP Heap-Based Buffer Overflow","id":"CVE-2019-5544","kev_date_added":"2021-11-03","published":"2019-12-06"},{"cvss_score":9.6,"headline":"Google Chromium V8 Type Confusion","id":"CVE-2024-4947","kev_date_added":"2024-05-20","published":"2024-05-15"},{"cvss_score":9.6,"headline":"Google Chromium Visuals Use-After-Free","id":"CVE-2024-4671","kev_date_added":"2024-05-13","published":"2024-05-09"},{"cvss_score":9.6,"headline":"Google Chromium Mojo Insufficient Data Validation","id":"CVE-2022-3075","kev_date_added":"2022-09-08","published":"2022-09-26"},{"cvss_score":9.6,"headline":"Google Chromium Indexed DB API Use-After-Free","id":"CVE-2021-30633","kev_date_added":"2021-11-03","published":"2021-10-08"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-06","vendors":["n/a"]},"summary":"Remote attackers can cause denial of service via resource consumption using crafted strings in the BSON ObjectId validation method.","url":"https://insights.sbomify.com/CVE-2015-4411/"}