CVE-2015-4412 bson is vulnerable to denial of service due to incorrect regex validation
Remote attackers can cause denial of service or inject arbitrary data via crafted strings in the Ruby BSON library.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2015-4412?
CVE-2015-4412 is a critical denial of service vulnerability in n/a, published on 5 Feb 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
BSON injection vulnerability in the legal? function in BSON (bson-ruby) gem before 3.0.4 for Ruby allows remote attackers to cause a denial of service (resource consumption) or inject arbitrary data via a crafted string.
Weakness: CWE-400
Which versions are affected by CVE-2015-4412?
4 open source packages ship an affected version, including bson. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
bson RubyGems | All versions | 1.12.3 |
bson RubyGems | All versions | 1.12.3 |
bson RubyGems | From 2.0 | 3.0.4 |
bson RubyGems | From 2.0 | 3.0.4 |
Products include Bson Project Bson.
How do I fix CVE-2015-4412?
Upgrade bson to a fixed version for your release line: 1.12.3 or 3.0.4.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2015-4412 being exploited?
There is no known exploitation of CVE-2015-4412 in the wild and no public exploit code.
Sources
Also known as GHSA-h6rj-8r3c-9gpj.